Piwik stopped tracking > ‘There is no data for this report.’ (Piwik 2.16.1 & 2.16.2-b2 )

Dear Forum,

June 27 was the last day Piwik 2.16.1 tracked any data. A few days ago I began wondering why the days started showing 0 for all stats. The Visitor Log only shows “There is no data for this report.”

There were no changes of any kind made to Piwik. There was one minor edit in Apache 2.4 for the Piwik host from Require all allowed to Require all denied just so the Piwik login would not be open to the world. To rule out any issues with this the change was reverted but Piwik continued to not track data. Here is a graph showing the steady decline.

I thought this Piwik problem was similar to [SOLVED] Piwik stopped tracking / Actions > ‘There is no data for this report.’ (Piwik 2.15.0), but changing the data type from int to bigint made no difference. I deleted my own tracking cookie in Piwik so my own visits could be tracked just to help quickly determine if it would begin tracking again.

Here is what I have done so far with no change in reporting behavior.

  1. changed data type for Table piwik_log_link_visit_action.idlink_va from int to bigint

  2. verified what latest updates on Linux host have been performed around the time Piwik stopped tracking (June 27), but found nothing relevant in the install/update logs to what Piwik would depend on. The only major updates performed several days before Piwik broke was for PHP on June 22, but Piwik was still working fine up until June 27. The same php.ini file is still in place from when Piwik was still working, so nothing here was modified to cause Piwik tracking to break.

  3. monitored Piwik debug logs per faq_115 but found no problems related to tracking. All that was shown in debug was a list of enabled plugins. Changed logging to ERROR mode but no errors were produced when performing actions in the Piwik web UI.

  4. git cloned 2.16.2-b2 and upgraded database successfully in the Piwik web interface, but There is no data for this report continued to show.

  5. verified auto archiving = enabled. I don’t see this being a problem as the tracked websites only get about maybe 100 hits per day or maybe a little more, so not huge amounts of traffic.

  6. changed code in piwik/core/DataAccess/RawLogDao.php for function createTempTableForStoringUsedActions so idaction int(11) is now idaction BIGINT as described in https://github.com/piwik/piwik/issues/3288

  7. Apache logs for the Piwik host shows a few of these entries:
    [Thu Jul 07 01:39:44.848028 2016] [authz_core:error] [pid 31819] [client 180.76.xx.xxx:57658] AH01630: client denied by server configuration: /usr/share/webapps/piwik/piwik.js, referer: https://site.domain.net/node/10 but Piwik is allowed in php.ini basedir. No changes to this file were made.

Additional Details

$ apachectl -v
Server version: Apache/2.4.20 (Unix)
Server built: Apr 11 2016 10:04:04

$ php -v
PHP 7.0.8 (cli) (built: Jun 22 2016 16:45:35) ( NTS )
Copyright (c) 1997-2016 The PHP Group
Zend Engine v3.0.0, Copyright (c) 1998-2016 Zend Technologies

$ pm -Q composer
composer 1.1.3-1

I think I have exhausted most things I could think of and come here to see if anyone can shed some light on this situation. :slight_smile:



do you see data in Visitors > Visitor log? if so , it means your data is tracked properly. The problem would be with the archiving then.

if you have no data in the Visitor log then data is not tracked properly.

Thank you for your response, matthieu.

I see no data in Visitors > Visitor log – only “There is no data for this report.”. The strange thing is data was being tracked for several months before June 27 when it stopped tracking. The tracking code is still the same has not been changed.

This has been resolved.

After cross checking all events for June 27 it turns out the problem was due to an Apache config change. Require all granted was changed to Require all denied

<VirtualHost *:80>
  AllowOverride None
  Require all denied <--problem
  Require ip xxx.x.x.xx xxx.xxx.xxx.xxx

This was done in an effort to prevent unauthorized users from accessing the Piwik login page. Instead of using a traditional .htaccess to password protect a web directory, I have been using LDAP authentication for different web directories successfully, but I can’t figure out why piwik won’t prompt for authentication when providing the path to piwik in Apache. Only thing I could think of is I would need to specify a different subdirectory where piwik lives (/path/to/piwik), but I don’t think this is necessary. I have been following this issue Lock down accounts by IP after N failed attemps at logging · Issue #2888 · matomo-org/piwik · GitHub but would like to implement some solution in the meantime. Open to suggestions :slight_smile:

<Directory "/path/to/piwik">
  AuthName "This Restricted Area Requires LDAP Authentication"
  AuthType Basic
  AuthBasicProvider ldap

So the issue is resolved and was unrelated to piwik itself. Apologies for the noise.