Piwik stop collecting data


#1

Hi,

I didn’t do anything and suddenly Piwik stop collecting data on the visitor log page, so I can’t see where are users coming to my site.

What should I do?

Thanks!


(Matthieu Aubry) #2

Check that there is no JS error, check your server error logs ?


#3

Hi,

I don’t see any JS error, checked the server logs - no problem.
I have 2 sites with Piwik, one of them still collecting data, but the other isn’t (and it worked fine before)

Any more sugestions?

Thanks!


(Matthieu Aubry) #4

See: Troubleshooting - Analytics Platform - Matomo


#5

My chat log with HostGator regardin this same problem:

(9:11:06pm)Jonatan B.:I am seeing that there is a security rule being hit by the software I can clear this out for you if you wish me to.
(9:11:27pm)Phillip Crum:Explain it to me in English, please. Slowly.
(9:12:02pm)Jonatan B.:Its no problem
(9:12:26pm)Jonatan B.:It seems that the software Piwik is trying to do something that is consider unsafe, by default, but we all know its not so we can clear out this warning
(9:12:36pm)Jonatan B.:Kind of like a false positive on your Antivirus.
(9:12:55pm)Phillip Crum:Why all of a sudden? New setting last nite?
(9:13:59pm)Jonatan B.:No, they can be hit by any number of reasons and then they get blocked until cleared.
(9:14:26pm)Phillip Crum:Funny that many others are having the same problem simultaneously??
(9:14:41pm)Phillip Crum:How do I keep this from happening again?
(9:17:15pm)Jonatan B.:All we have to do is whitelisted and that will take care of it.


#6

Altstatten - Thanks - I’ve checked it and they told me there isn’t a problem

Matt - Thanks - I’ve tried everything I’m understanding - I can’t see any problem, I probably ask someone more expert

If you have any idea - let me know.

Thanks!


#7

It could be a big help for me too if any comes up with a more conclusive solution…thanks!


#8

OK, I’ve found the problem I had:
for some reason the code in the site was "var pkBaseURL = ((“https:” == document.location.protocol) ? “https://www.mysite.com/” : "http://www.mysite.com/");"

It should be without the “www.”:
for some reason the code in the site was "var pkBaseURL = ((“https:” == document.location.protocol) ? “https://mysite.com/” : "http://mysite.com/");"

I hope it will help you!