Piwik sous débian et joomla


#1

Bonjour,

Lorsque je me connecte à Piwik, il n’y a rien qui s’affiche à part les menus et les titres.
Pourtant j’ai bien des données dans la Base MySQL. Mais le système est lent et sans rien dans le tableau de bord.
J’ai cru dans un premier temps à un soucis de connexion Anonyme, mais quelqu’un m’a dit que ce message était normal (dans les paramètres).
Ensuite j’avais bien un soucis de suhosin.memory_limit = que j’ai passé à 256M --> plus d’ALERT dans syslog.
Mais toujours rien.

Auriez-vous déjà rencontré ce soucis ?

David,


(Matthieu Aubry) #2

Bonjour, dans le System Check est ce qu’il y a un message ou tout est bon ? Peux tu envoyer un screenshot ?


#3

Merci Matt pour tes remarques.
Alors oui j’ai regardé dans le system check, et il y avait un “blocage” au niveau des “eval”. J’ai donc mis à “off” le paramètre suhosin.executor.disable_eval. Après avoir redémarrer apache2, l’erreur de se fait plus. Et le system check me dit : Huzzah !!!
Par contre je n’ai toujours aucune information dans mon dashboard. Il me semble que cela peut venir de Suhosin, mais je ne sais pas où regarder ?
Serveur DEBIAN 7 kernel2.6.32
Serveur MySQL 5.1.72-2
Apache2
PHP5 avec extension Suhosin

Si tu as une idée, je suis preneur…


(Matthieu Aubry) #4

Regarde dans ton log d’erreur de ton web server ?


#5

J’ai 3 erreur fatale PHP : Maximum exécution time of 30 secondes exceeded in …/vendor/tedivm/jshrink/src/JShrink.Minifier.php dans 3 lignes différentes (177,273,274), referer : …/index.php?, …/index.php?module=login, …/index.php?module=CoreHome…


(Matthieu Aubry) #6

@David vois la FAQ: Piwik reports this error and doesn't continue: "Fatal error: Maximum execution time of 30 seconds exceeded in ..." - Analytics Platform - Matomo


#7

Merci, mais j’ai modfier comme indiqué le php.ini dans /etc/php5/ … Rien n’y fait.
j’ai modfier comme indiqué le php.ini dans /etc/php5/cli … Rien n’y fait.

Je suis vert, je continue mes recherches …

David,


(Matthieu Aubry) #8

Merci de demander a ton webhost d’augmenter la limite, ou bien si tu le fais toi meme sois sur de redemarrer le serveur apres avoir change le CLI et le APACHE2 php.ini


#9

J’ai :

  • mis la variable MAX_EXECUTION_TIME=0 dans php.ini de CLI et APACHE2 dans /etc/apache2
  • redémarrer le service apache2 via service apache2 restart

ET CA MARCHE !!!

MERCI MAT !!!