Piwik on Lunarpages shared hosting plan - doesn't work


#1

I cannot get any visitor data to display, is this a known problem with Lunarpages? I’ve tried both the Softaculous install provided by Lunarpages, and the manual instal (where the install wizard said the installation was a success).

I did notice one post here where it was suggested that they tell their hosting provider (HostGator, not Lunarpages) to disable “mod_security” on their host. Would this be the cause of my problem with Lunarpages shared hosting service?

Thank-you for any help …


#2

Well, I just tried the test recommended in this post, and on the first test it just goes to my login page (not sure if I’m doing that test the proper way), but second test passes (it goes to the “Piwik is a free open source …” message). So perhaps I already have a disabled mod_security setting on my host.

What else could be causing the problem?


#3

I’ve been in contact with Lunarpages tech support, and they told me to verify that “PHP5” was selected in cPanel’s PHP Configure. It was showing “Default”, even though cPanel shows PHP v5.2.17 installed, so I changed it to “PHP5” and hit update. I then, after removing the old one, re-installed Piwik.

It still doesn’t work :frowning:


#4

[quote=rupes]
I’ve been in contact with Lunarpages tech support, and they told me to verify that “PHP5” was selected in cPanel’s PHP Configure. It was showing “Default”, even though cPanel shows PHP v5.2.17 installed, so I changed it to “PHP5” and hit update. I then, after removing the old one, re-installed Piwik.

It still doesn’t work :([/quote]

I work for Lunarpages. Please e-mail support@lunarpages.com to ask them to assist you with the WordPress install and provide them with the current issues you’re experiencing. Our support team will be more than happy to assist you.


#5

[quote=lunarpages]

[quote=rupes]
I’ve been in contact with Lunarpages tech support, and they told me to verify that “PHP5” was selected in cPanel’s PHP Configure. It was showing “Default”, even though cPanel shows PHP v5.2.17 installed, so I changed it to “PHP5” and hit update. I then, after removing the old one, re-installed Piwik.

It still doesn’t work :([/quote]

I work for Lunarpages. Please e-mail support@lunarpages.com to ask them to assist you with the WordPress install and provide them with the current issues you’re experiencing. Our support team will be more than happy to assist you.[/quote]

I’ve been in contact with them, see above. I ended up asking them to verify that mod_security had been disabled on my server, and they replied that it wasn’t, but is now. :slight_smile:

Hopefully it was the mod_security setting that caused my setup problem. When I have time, I will be removing the current Piwik install and then creating a new one under the disabled mod_security environment. Keepin my fingers crossed.

Thanks for the help. At least now I know that it SHOULD work on Lunarpages :slight_smile:


#6

And still not working :frowning:

I’m running out of ideas. I did find this PHP.ini file in my main PUBLIC_HTML directory, but I don’t see how it could be the cause:

PHP.ini


register_globals = Off

[Zend]
zend_optimizer.optimization_level=15
zend_extension_manager.optimizer=/usr/local/Zend/lib/Optimizer-3.2.6
zend_extension_manager.optimizer_ts=/usr/local/Zend/lib/Optimizer_TS-3.2.6
zend_optimizer.version=3.2.6
zend_extension = /usr/local/ioncube/ioncube_loader_lin_4.4.so

zend_extension=/usr/local/Zend/lib/ZendExtensionManager.so
zend_extension_ts=/usr/local/Zend/lib/ZendExtensionManager_TS.so


And this is the script I’m placing before the last tag in my INDEX.html of the site I want tracked (I checked the source from my browser, and the code is there):


<!-- Piwik --> 
<script type="text/javascript">
var pkBaseURL = (("https:" == document.location.protocol) ? "https://analytics.mydom.com/" : "http://analytics.mydom.com/");
document.write(unescape("%3Cscript src='" + pkBaseURL + "piwik.js' type='text/javascript'%3E%3C/script%3E"));
</script><script type="text/javascript">
try {
var piwikTracker = Piwik.getTracker(pkBaseURL + "piwik.php", 1);
piwikTracker.trackPageView();
piwikTracker.enableLinkTracking();
} catch( err ) {}
</script><noscript><p><img src="http://analytics.mydom.com/piwik.php?idsite=1" style="border:0" alt="" /></p></noscript>
<!-- End Piwik Tracking Code -->

The install script reported a perfect install with no errors or warnings. I double checked the MySQL db that I created for Piwik, and it went from 0MB to 0.06 MB after install.

Any other possible causes?


(Matthieu Aubry) #7

See Troubleshooting - Analytics Platform - Matomo


#8

[quote=matt]
See Troubleshooting - Analytics Platform - Matomo

That was the first place I went. :slight_smile:

I think I may have another item for that FAQ :smiley:

I’m such an idiot. I completely forgot that I have GlimmerBlocker and Ghostery installed and active. So I am fairly certain that one of those, or both, is the cause of my headaches.

I’ll verify whether that is the problem later on tonight and report back …


#9

Yup, it was Ghostery blocking the tracking code 8-), so all is working now :slight_smile:

You may want to add “Check to make sure you don’t have any ad or tracking blockers, like Ghostery, enabled when using your own browser to test to see if Piwik is working.” to that FAQ. :smiley:


(Matthieu Aubry) #10

Good point, I added that!


#11

[quote=matt]
Good point, I added that![/quote]

Great! At least my stupidity may help others. :slight_smile:


(Matthieu Aubry) #12

It’s not stupid so don’t worry :wink: