Piwik not working after upgrade to 1.11.1

I’ve encountered a problem after the last Piwik upgrade. Al the previous upgrades have worked seamlessly. When I chose to automatically upgrade to 1.11.1, it appeared to go as normal, and I got to a page that said it was successful with a link to “Continue to Piwik” as I always have.

After this I usually get a second page telling me that the DB aso has to be upgraded. I never got this page on this upgrade (not sure if I should’ve, but I thought I’d mention it).

When my Piwik home page came up, none of the widget even attempt to load. I basically get a blank page with only the header. None of the links seem to work. The drop down which normally shows my web sites is there, but seems disabled (doesn’t drop-down). Same with the “date range” calendar widget.

Any advice on how to un-do or re-do the installation?

Thanks so much!

see: Troubleshooting - Analytics Platform - Matomo

Thanks Matt! I had tried clearing the browser cache, but I failed to see the checkbox in IE that reads “Preserve Favorites Website Data”. So it wasn’t clearing the cache for Piwik. It’s back up.