Piwik mobile error to connect to my piwik but not on demo


#1

Hi,
I have a problem with Piwik Mobile for Android.
I can’t connect to my piwik install (nginx server with php-fpm) but it works with demo.piwik.org.
I’ve enabled anonymous access if you want to test.
The problem is with my install.

Piwik Mobile :
Platform : android 2.3.7 U20i
Version : 1.6.1 - 1.8.0 03b8453
Available memory : 3191720
Resolution : 240x320 low (120)
Locale : fr-FR
Network : WIFI

Server :
Platform : Debian GNU/Linux Squeeze & Debian GNU/Linux SID (apt-pinning for nginx & php5-fpm)
Version : 1.6
URL : http://piwik.colundrum.eu

Nginx data webhost :


server {
        listen   80;

        root /var/www/piwik;
        index index.php index.html index.htm;

        server_name piwik.colundrum.eu;

        if ($request_method !~ ^(GET|HEAD|POST)$ ) {
            return 444;
        }

        location ~* ^.+\.(?:jpg|png|css|gif|jpeg|js|swf)$ {
                 expires max;
        }

        location ~* ^.+\.(?:jpg|png|css|gif|jpeg|js|swf)$ {
                 expires max;
                 break;
                 tcp_nodelay off;
        }

        location = /favicon.ico {
                 try_files /favicon.ico =204;
        }

        location / {
                 try_files $uri /index.php;
        }

        # pass the PHP scripts to FastCGI server listening on 127.0.0.1:9000
        #
        location ~* ^/(?:index|piwik)\.php$ {
                fastcgi_pass unix:/var/run/php5-fpm.socket;
                include fastcgi_params;
        }

        location ~* ^.+\.php$ {
                  return 404;
        }

        location ~* ^/(?:README|LICENSE[^.]*|LEGALNOTICE)(?:\.txt)*$ {
                 return 404;
        }

        # deny access to .htaccess files, if Apache's document root
        # concurs with nginx's one
        #
        location ~ /\.ht {
                deny all;
        }
}

Fastcgi_params :


fastcgi_param   QUERY_STRING            $query_string;
fastcgi_param   REQUEST_METHOD          $request_method;
fastcgi_param   CONTENT_TYPE            $content_type;
fastcgi_param   CONTENT_LENGTH          $content_length;

fastcgi_param   SCRIPT_FILENAME         $request_filename;
fastcgi_param   SCRIPT_NAME             $fastcgi_script_name;
fastcgi_param   REQUEST_URI             $request_uri;
fastcgi_param   DOCUMENT_URI            $document_uri;
fastcgi_param   DOCUMENT_ROOT           $document_root;
fastcgi_param   SERVER_PROTOCOL         $server_protocol;

fastcgi_param   GATEWAY_INTERFACE       CGI/1.1;
fastcgi_param   SERVER_SOFTWARE         nginx;

fastcgi_param   REMOTE_ADDR             $remote_addr;
fastcgi_param   REMOTE_PORT             $remote_port;
fastcgi_param   SERVER_ADDR             $server_addr;
fastcgi_param   SERVER_PORT             $server_port;
fastcgi_param   SERVER_NAME             $server_name;

# PHP only, required if PHP was built with --enable-force-cgi-redirect
fastcgi_param   REDIRECT_STATUS         200;

Good day.


#2

Hey colundrum,

use “http://piwik.colundrum.eu/index.php” as url and it works. Otherwise your Piwik installation redirects to the dashboard.

Greetings Thomas


#3

Thanks but when I choose a website, I’ve got the same error and I’ve just:

  • Visitors in Real Time
  • Visitor Log

I use the French language.

edit : ok, it’s a bug in French language. In English, it works fine.


#4

I’m able to reproduce it with French and German language. Only Visitors in Real Time and Visitors Log is displayed. Have debugged it, but I have no idea what could cause it. The requested URL returns a valid json when testing in Browser (all languages). Works also fine in Android 2.3.3 Simulator with all languages. But on my Android device (2.3.3) if language is French or German the request only receives the first 20288 characters. If language is English, the request receives all about 48000 characters…

Same device and account demo.piwik.org works also fine with all langauges


#5

I use a Android 2.4.6