Piwik migration to new server, same (old) piwik version (1.12) , mysqldump


#1

I’m trying to migrate Piwik to a new server, the actual version is 1.12, my idea was to stay with the same version, util everything is up and working on the new server, and only then i will try to upgrade version. This way I initially avoid uncompatibility with database dump and piwik version.

Systems Informations:

  • Source server(actual one) : OS GNU/linux CentOS 5.11
  • Destination server(new one) : OS GNU/linux CentOS 6.5
  • Piwik version on source server is old (1.12)
  • Piwik on destination server will be 1.12 in the initial stage, just to semplify situation.

The first procedure I adopted was:

  • compress /var/www/piwik folder, in a tar archive for avoid unix permission loss.
  • dump the piwik database (mysqldump)
  • scp/upload the tarball & the mysql dump to the destination server
  • untar piwik webapp and setup the vhost accordingly
  • import dump.sql into mysql, create ‘piwik’ db user & grant permission on his database
  • fix the configuration in $PIWIK_HOME/config/config.ini.php accordingly to the database configuration.

The result is that all the Analytics data is not there. The connection to the db seems to work , also the system check did not returned errors. I can login whit same credentials used in the old instance, and also other data seems to have been imported correctly. But all the Analytics data is gone. All the graph are empty.

I’m trying to understand where is the problem. But i cannot find useful log files for this purpose. Could I activate logging / debugging mode some how?

I’ve also tried an alternative migration procedure; where instead of tarring and migrating same instance already deployed in the old server, I downloaded again piwik version (1.12), and executed fresh install. The rest of the procedure was the same. And the final result was also the same, all the analyics data is not displayed.

my last try is been to import the database, drop all the tables ‘piwik_archive_*’, reinstall piwik 1.12, and restart apache httpd. Piwik have recreated some piwik_archive tables using the data in the other tables. But final result still the same.

Somebody has any idea about what am I doing wrong? please let me know if i’m missing to provide informations


#2

SOLVED
the mysql dump was corrupted for some reasons,
re-executed the dump and import, and it worked like a charm

sorry for the post, it can be deleted


(Matthieu Aubry) #3

Hi there, dont forget to upgrade to latest piwik! 1.12 has many security vulnerabilities we have since fixed. Thanks