Piwik Installation


#1

Hello!

I’m just getting started with piwik. I’ve uploaded the files to my shared sever and was able to get to the welcome screen at /piwik/. I pressed next, and the system check was completed with a few errors.

Tracker status:
404
GET request to piwik.php failed. Try whitelisting this URL from mod_security and HTTP Authentication.

. Also, when I press next on the bottom of the page, it brings me to a page not found.

If someone could help me get this set up I would really appreciate it.

Thanks!


(Matthieu Aubry) #2

See Troubleshooting - Analytics Platform - Matomo


#3

[quote=matt]
See Troubleshooting - Analytics Platform - Matomo

Thanks for your response! Could you please tell me in which file I can find this line? Also, will this fix the issue of the Database Setup getting the not-found page?


(Matthieu Aubry) #4

You shoul dcontact your webhost so that he disables mod_security from your server


#5

Okay I will do that. Thanks for your response!


#6

My hosting provider has disabled Mod_security for my domain. However, It’s still not working. Attached is a screenshot.

Also, once I press the next button on the bottom of the page, it brings me to /piwik/?action=databaseSetup&trackerStatus=404 . Page not found.

Thanks for your help.


#7

My hosting provider was finally able to fix the mod_security so that part works fine. However, I can’t get past the systems check page: /piwik/?action=databaseSetup&trackerStatus=0 . I get a Page not found error. If someone can help me with this please pm me.

Thanks for all the support.


#8

I was finally able to get through!! The Bullet Proof Security plugin was the problem!


#9

Hi,

I am getting the same error but with number 500. Any help is appreciated.


(Matthieu Aubry) #10

@ecafe what error are you getting? could you paste the error.log log line for this error?


#11

The error is on the second screen during installation:

Tracker status 500
GET request to piwik.php failed. Try whitelisting this URL from HTTP Authentication and disable mod_security (you may have to ask your webhost).
After making this change, restart your web server.

Mod_security is disabled. Apparently I can only whitelist IP addresses, not URLs.

Thanks.

P.S. attached screen image

[attachment 1867 piwik.gif]


(Matthieu Aubry) #12

Check in your server error log -> what error do you see there? maybe it’s not caused by mod_security but by some other settings on your server (if so we’d like to upgrade the FAQ and error message to tell users)