Piwik installation is triggered when piwik is already installed (after upgrading to php5.5.7 and enabling opcache)


#1

as in the title here, i updated php to 5.5.7 and enabled the opcache.
when i restarted the services for mysql, nginx and php-fpm i visited piwik and saw that the install process page was rendered and the message in a red error type box:

Your Piwik configuration file appears to be misconfigured. You can either remove config/config.ini.php and resume installation, or correct the database connection settings.
sqlstate[hy000] [2054] the server requested authentication method unknown to the client

anyone know why this is ?

piwik v. 2.0.2


#2

i gave up with this and reinstalled piwik totally. i thought i would be able to keep the database data but the installer only gave me the option of dropping it and creating fresh tables… so i did that since i am not particularly bothered about keeping the data at this point.


(Matthieu Aubry) #3

The SQL error you saw was not a Piwik bug but a Mysql ugprade issue see eg. pdo - MySQL remote connection fails with "unknown authentication method" - Stack Overflow - maybe this helps another user who may have same error

Otherwise good to know are you up and running.


#4

ah ok, yes, i did already change the password and disabled the older format for mysql passwords. the lack of clarity in the error message confused me!


#5

I have run into the same problem after upgrading PHP.

Is it the mysql user password that needs to be updated, and if so, can I simply create a new user and add it to the config.ini.php file?

I assume that if I downgrade PHP to the original version, things will go back to normal. If that’s the case, how do I upgrade the software so it will work after upgrading back to PHP a newer version?


#6

Uhm, why isn’t the most obvious Help not written down here? I had to check my old install with a new one to fine that help, maybe it helps other ppl who have same issue like me:

The old config looks like
[database]
host = "localhost"
username = "USERNAME"
password = "YOURPASSWORD"
dbname = "DBNAME"
tables_prefix = "piwik_"
charset = “utf8”

and the NEW needs to look like
[database]
host = "localhost"
username = "USERNAME"
password = "YOURPASSWORD"
dbname = "DBNAME"
tables_prefix = "piwik_"
adapter = "MYSQLI"
charset = “utf8”

After i added this adapter like, everything just worked fine!


#7

Changing the password here after upgrading PHP to 5.5 can also work.