Piwik-Error-Meldung nach dem Einloggen


#1

Hallo Piwik-Forum,

nach dem Einloggen erhalte ich folgende Meldung:

There is an error. Please report the message (Piwik 2.8.3) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined variable: currentLogin in /www/htdocs/w00fffc0/piwik/core/Plugin/Controller.php on line 850

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [/www/htdocs/w00fffc0/piwik/core/Plugin/Controller.php:850]
#1 Piwik\Plugin\Controller->redirectToIndex(…) called at [/www/htdocs/w00fffc0/piwik/plugins/CoreHome/Controller.php:112]
#2 Piwik\Plugins\CoreHome\Controller->redirectToCoreHomeIndex(…) called at [:]
#3 call_user_func_array(…) called at [/www/htdocs/w00fffc0/piwik/core/FrontController.php:587]
#4 Piwik\FrontController->doDispatch(…) called at [/www/htdocs/w00fffc0/piwik/core/FrontController.php:95]
#5 Piwik\FrontController->dispatch(…) called at [/www/htdocs/w00fffc0/piwik/core/dispatch.php:34]
#6 require_once(…) called at [/www/htdocs/w00fffc0/piwik/index.php:46]

There is an error. Please report the message (Piwik 2.8.3) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Notice: Undefined variable: currentLogin in /www/htdocs/w00fffc0/piwik/core/Plugin/Controller.php on line 850

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [/www/htdocs/w00fffc0/piwik/core/Plugin/Controller.php:850]
#1 Piwik\Plugin\Controller->redirectToIndex(…) called at [/www/htdocs/w00fffc0/piwik/plugins/CoreHome/Controller.php:112]
#2 Piwik\Plugins\CoreHome\Controller->redirectToCoreHomeIndex(…) called at [:]
#3 call_user_func_array(…) called at [/www/htdocs/w00fffc0/piwik/core/FrontController.php:587]
#4 Piwik\FrontController->doDispatch(…) called at [/www/htdocs/w00fffc0/piwik/core/FrontController.php:95]
#5 Piwik\FrontController->dispatch(…) called at [/www/htdocs/w00fffc0/piwik/core/dispatch.php:34]
#6 require_once(…) called at [/www/htdocs/w00fffc0/piwik/index.php:46]

Wer kann mir weiterhelfen?

MfG
didi


(Stefan Giehl) #2

Ich hab mir das mal angesehen. Da war wirklich ein Fehler im Code, der allerdings bereits gefixt wurde.
In der aktuellen Beta sollte das schon gehen.


#3

Lieber Administrator,

vielen Dank für Deine Antwort! Ich habe gerade versucht, mich anzumelden.
Leider geht es immer noch nicht!

Beste Grüße
didi


(Stefan Giehl) #4

Dafür müsste Piwik auf dem Server auf die letzte Beta aktualisiert werden, was sicher nicht automatisch passiert ist.
Bist du der Administrator oder nur ein Nutzer einer Piwik-Instanz?


#5

Administrator ist mein Webmaster, Kenn Henley. Ich bin nur Nutzer.

Beste Grüße
didi


(Stefan Giehl) #6

Lass diesen Mal nachsehen ob für deinen Benutzer ausreichende Berechtigungen hinterlegt sind. Der Fehler sollte nur auftreten wenn Berechtigungen fehlen. Dein Webmaster sollte auch auf die aktuelle Beta-Version aktualisieren können.


#7

OK, ich gebe Ihre Nachrichten an ihn weiter.

Beste Grüße
didi


#8

Hat geholfen. Danke, SteveG.


#9

Kann es sein, dass die letzte Antwort nicht vom Administrator SteveG stammt? Sein Name ist “SteveG” und nicht “steeph”!?!?

Beste Grüße
didi


#10

Ja, der Post vor deinem letzten war von mir.


#11

Danke!