Piwik couldn't write to some directories


#1

I get this message from piwik after a server software update:

Piwik couldn’t write to some directories.

Try to Execute the following commands on your server:

chmod 0777 /home//public_html/piwik/tmp/templates_c
chmod 0777 /home/
/public_html/piwik/tmp/cache
chmod 0777 /home//public_html/piwik/tmp/assets
chmod 0777 /home/
/public_html/piwik/tmp/tcpdf
If this doesn’t work, you can try to create the directories with your FTP software, and set the CHMOD to 0777 (with your FTP software, right click on the directories, permissions).

There is no way to chmod these directories with filezilla. Filezilla returns message: 550 CHMOD 777 cache: Operation not permitted.

I tried from cpanel’s ftp. I even tried to delete the folders. Nothing happened.

Apache 2.2, MySQL 5.5, PHP 5.3.10.
Extra cron from previous version: Mod Ruid2

Please advice


(Matthieu Aubry) #2

Try 755?


#3

They are already 755


#4

Take a look at: http://setworldup.com/piwik/


(Matthieu Aubry) #5

Can you “Chown” and set it to your web user (maybe called apache2 ?)


#6

Apologies for opening an old post. @setworldup, would you be able to explain what you did to fix this issue. It seems that I am having the exact same problem. Thanks in advance.