piwik_archive_blob tables stopped updating


#1

Hello, my company has using using PIWIK successfully on wordpress sites for a few months now and everything has been working fine up until the month of July.

Since July 1st, no data is being inserted in the piwik_archive_blob tables.

I’ve tried deleting all the archive tables. The tables are recreated but no data is inserted.

I’ve also tried setting
[Debug]
always_archive_data_day=1
always_archive_data_period=1

in the confing.ini.php file with no change.

The system was set up on PIWIK 1.7.1. I have since updated to 1.8.2 with no change in the problem.

The only place in the dashboard where correct data is being shown is the “Visitors in Real Time” widget. All others show no current data.

Any help in debugging the issue would be greatly appreciated.


(Matthieu Aubry) #2

Please look in the web server error logs for any error ?

Do you run the cron to archive? check it’s still running. Also try to set “YES” to allow web cron in Geenral settings?


#3

Hi Matt,

Thanks for the response.

There aren't any entries in the errors table, but I have tracked the problem down to the cron job, but I have yet to get it to work. I've never set one up before, and I haven't had any luck yet with following your instructions for setting one up. Setting it to "Yes" in general settings isn't an option because the whole system times out after doing so, but the tables do seem to update afterwards.

Using the cron job, it says success after running, but the tables still don't update.

Also, I've tried pathing directly to the Archive.php with the auth token in the query string, but it returns me this error.

Fatal error: The Piwik URL http://webstats.pbhs.com/misc/cron/../../index.php does not seem to be pointing to a Piwik server. in C:\inetpub\wwwroot\piwik_stats\misc\cron\archive.php on line 519

Would this be a problem with my config.ini.php? Or something else?


(Matthieu Aubry) #4

Using the cron job, it says success after running, but the tables still don’t update.

can you please paste the output in pastebin to check it’s working correctly?

There aren’t any entries in the errors table,
Can you also check the Apache error log file?