Piwik and Oops… problem during the request,

I´m running an apache with suexec and php fcgi. Scripts like wordpress are running great. But piwik is very slow and shows up the message “Oops… problem during the request, please try again.”. The error.log of the apache says the following:

client denied by server configuration: /piwik/index.php, referer: Piwik › Error

I already checked the configuration on the vhost and any .htaccess. All looks good. Please find an example of my vhost configuration here: [Bash] <VirtualHost *:80> ServerAdmin me@example.com ServerName example.com - Pastebin.com

I tried it with Piwik 1.6 and Piwik 1.7-b10. On both of them I had the same problem.

Any help would be great


See the FAQ: Oops, there was a problem during the request

and this other FAQ: Piwik is slow - In particular the point number 3) should fix the issue for you

Hello matt,
thank you very much for your answer. I add the lines but it shows no effect. :-/

Best regards,

Did you add it below [General] in config.ini.php?

Ye, I add the [General] line and below of them, the line session_save_handler = dbtable.

client denied by server config … kind of says it all. What does your .htaccess look like?

Hello vipsoft,

please find my .htaccess of the / directory here: http://pastebin.com/w2eVuBQv
It only contains some rules for wordpress, w3c total cache plugin (for wordpress). I only denied some files of wordpress.
Also no .htaccess is in the directory of piwik.

So it looks like Piwik is in a sub directory off your main site.

.htaccess directives cascade into sub folders. I suspect the deflate is the problem because Piwik’s asset manager has already compressed the output.

You can either add an htaccess directive in the piwik folder to disable mod_deflate, or set disable_merged_assets in config.ini.php

Sorry for being terse/typos, I’m posting from phone

vipsoft, thank you so much! It works again! :slight_smile:
I have added isable_merged_assets in config.ini.php and now it is slow, but loads the full page. :smiley:

Thank you very much!

I’m using Apache and I was having the error a lot for the loading of blocks in the dashboard. Not always, though.

I suspected (given the very short time between the loading gif and the error) that this was related to some internal max_execution_time setting, so I changed the vhost configuration to force max_execution_time to 60 (inside the tag:

php_admin_value max_execution_time 60

Then I reloaded Apache and didn’t have the issue since the change yesterday.
Looking into the code, there is no obvious part where the max_execution_time is set to anything other than 0, but my php.ini file was setting it to max_execution_time=30 and the error was clearly appearing after only 5 seconds or less, hence the decision to try (just for that virtual host) with a php_admin_value, which ensures whatever PHP code running on this vhost will not be able to change that value through code.