Piwik 2.4.1 slow performance. Icons are loaded very slowly


#1

Hi there,

since we’ve updated to Piwik 2.4.1 icons/images are loaded very slowly. When I switch between sites it takes around 2-6 seconds until all images are loaded completely.

Are you able to reproduce this issue? ANy help?
This issue occurs on 2 Piwik installation


#2

Anyone?


(Matthieu Aubry) #3

There is no change in piwik 2.4.1 that should create slowness in images. have you setup the archiving cron? How to Set up Auto-Archiving of Your Reports - Analytics Platform - Matomo
this should help make Piwik fast in general.


#4

Yes, The archive cron is enabled and “Allow Piwik archiving to trigger when reports are viewed from the browser” is disabled.

However “Loading Visitor profile…” window still takes around 10 seconds to load. I am running PHP 5.4.


#5

Tomb what are you php.ini settings?

Clear out tmp folder contents and see if that helps?

Is it reports or dashboards that are slow?


#6

Thanks for your reply.

PHP 5.4 settings:
memory_limit 768M
max_execution_time 600
APC

Yes, I’ve already deleted tmp. It’s stalling on the Dashboard, Visitor Log page. Loading data…


#7

What if you delete and then re add that visitor log page to dashboard?


#8

Great idea, however it doesn’t fixes the performance.


#9

what version of python are you running?


#10

Python 2.7.3


#11

could you exactly copy paste the memory settings of php.ini? comment out any info that deals with security if applicable.


#12

Okay, I’ve re-uploaded a complete Piwik installation and replace all files. Loading Visitor profile… still takes approximately 10 seconds to load.

Which memory settings directives do you need?

memory_limit 768M
Database collation uses InnoDB
realpath_cache_size 16K
realpath_cache_ttl 120
user_ini.cache_ttl 300
session.cache_expire 180
apc.cache_by_default On
apc.canonicalize On
apc.coredump_unmap Off
apc.enable_cli Off
apc.enabled On

Using Piwik’s System Check shows no errors.


#13

This line

memory_limit 768M

Change it to

memory_limit = 768M


#14

This line is already correct! I typed in the memory_limit within my administration UI.

What else can I do?


#15

ok i wanted to have you check the syntax of teh actual php.ini file.

What UI administration are you using?


#16

Don’t know the ISP control panel name. I am really sure that the syntax is correct.


#17

Anyone?

Seems like I have to hope for a upcoming release fix.


#18

bump


(Matthieu Aubry) #19

We still haven’t reproduced this issue nor other users reported it. So we are not sure how to help you? Maybe it is a problem with your hosting provider?


#20

Matt, thank you for your reply. What else can I do to debug this kind of behaviour?

Loading times using the Piwik iPhone App are great. Database is 17.69MB