Piwik 2.14.0, not a single token works for widgets


#1

Hi,

I have updated two instances of Piwik to 2.14.0. For both installs all widgets do not work anymore within my CMS. Not a single auth_token is accepted anymore. Not even those from a superuser. All I get is:

Error: You can't access this resource as it requires an 'view' access for the website id = 22.

To reproduce (with a normal user or superuser):

  • Login to Piwik
  • Go to API and copy/paste token
  • Go to Widgets, choose one and open the direct link in a new window
  • Logout of Piwik from previous tab
  • Re-open widget tab and add the following param &token_auth=xxxx (your token)

Is this a known issue? I assume more people suffer this.

Fact this happens for superusers too is not right I assume. Tests with normal users had 100% view/ admin access.


(Matthieu Aubry) #2

Hi there,

This one is a big regression, thank you for letting us know. I created a bug report at: Embedding widgets with token_auth does not work anymore · Issue #8321 · matomo-org/piwik · GitHub