Piwik 1.7 archive.php DNS Network Error


#1

I searched the different forums and such and could find anything that addressed this specifically. If there is something and someone can point me to it, that would be appreciated.

Just upgraded to 1.7 and tried running archive.php and I get the following error:

Network Error (dns_unresolved_hostname)
Your requested host “my.system.name here.com” could not be resolved by DNS.

For assistance, contact your network support team.

The system name is resolvable by DNS and the archive.sh script still seems to work fine.

I am sure I am missing something. Any help would be most appreciated.


(Matthieu Aubry) #2

It means that CURL in the archive.php was not able to resolve the domain name. Strange. When you do a “wget $domain” on your server does it work?


#3

I do a “wget http://myserver.mydomain.com” and I do get a response and no error.


(Matthieu Aubry) #4

What if you execute in your browser, domain/piwik/misc/cron/archive.php?token_auth=TOKEN_AUTH_SUPER_USER - does it work in this case?


#5

I have tried the following:

http://frevvo.es.dupont.com/piwik/misc/cron/archive.php?TOKEN_AUTH_SUPER_USER&token_auth=xxxxxxxxxxxxxxxx

http://frevvo.es.dupont.com/piwik/misc/cron/archive.php?token_auth=TOKEN_AUTH_SUPER_USER&token_auth=xxxxxxxxxxxxxxxx

http://frevvo.es.dupont.com/piwik/misc/cron/archive.php?token_auth=TOKEN_AUTH_SUPER_USER

and I get the following error:

You must specify the Super User token_auth as a parameter to this script, eg. &token_auth=XYZ if you wish to run this script through the browser.
However it is recommended to run it via cron in the command line, since it can take a long time to run.
In a shell, execute for example the following to trigger archiving on the local Piwik server:
$ /path/to/php /path/to/piwik/misc/cron/archive.php


(Matthieu Aubry) #6

Do this: http://frevvo.es.dupont.com/piwik/misc/cron/archive.php?token_auth=TOKEN_AUTH_SUPER_USER

and replace the TOKEN_AUTH_SUPER_USER
by your 32 characters super user token_auth