Php version is out of date but PEAR is up to date


#1

Here’s the error I am getting:
“Warning: include_once(./include/cache.class.php): failed to open stream: No such file or directory in /home/mwcarrera/rabidpixels.org/digitalmedia/include/functions.inc.php on line 40”

It appears that the php version is out of date but the PEAR is up to date!!! How do I fix this?


(Stefan Giehl) #2

Which version of PHP are you using? Piwik needs at lest 5.3.27 or higher


#3

Hear is what I know.

Using Dreamhost for my site
Piwigo is the ‘One Click Install’ app
My site, rabidpixels.org, has been down for a few weeks
DHost techs worked on it from their side, they say its a problem with the PHP out of date and the PEAR is up to date.

When I go to the app management window on the DHOST website, I have the latest version.

I have done a few updates with the app since 2013, the last update rendered my Pwigo useless and I have not been able to get it back online nor has the tech service at Dreamhost.

Please let me know what to look for, or I can give admin rights to someone to have a look at it from the back end…its not a big site nor hold any real value other than for family and friends.


(Matthieu Napoli) #4

I would even recommend to upgrade to 5.4 or higher since Piwik will drop 5.3 support soon (in June-July)


#5

You obviusly did not read my post, the version I have is the latest version I know of and available…it says I cannot updat into the future…


(Matthieu Napoli) #6

No need to be snarky, we obviously posted at the same time so I didn’t see your latest comment…


#7

Oklay, not meant to be…the issue is I have the latest update and no way to move forward…


(Matthieu Aubry) #8

This file in the error message does not seem related to Piwik: /home/mwcarrera/rabidpixels.org/digitalmedia/include/functions.inc.php

do you have other errors in error log? maybe try to reupload all files from 2.13.1?


#9

Matt, thanks for the reply…

Here is what I did to get pass the inability to update. I created a new photo gallery. Can I transfer the photo files from the old galler into the new one and if so, whats the best way to do that…I tried one gallery, follwing the code back into the root file, moved the file over to the new root file, but nothing happens when I go into the front side of the gallery. Its as if nothing is there…I suspect I might need to have DreamHost move those files on the server to create the right directory etc. How does this sound?