Php-fpm settings when using QueuedTracking plugin

Hi!
We have Matomo installed on two servers with 8 CPU and 8 GB ram. We use php-fpm and we have the default values for pm.* settings. We have set the minimum_memory_limit to 4096 MB. We use QueuedTracking plugin with Redis (numQueueWorkers=8).
When testing high load it seems to work ok up to 220 req/s. The problem is that the GUI then is responding very slow and sometimes doesn’t respond at all. The memory usage never goes higher than 1.8 GB. I tried to change the pm.max_children setting, but when increasing over the default 50, almost all requests are stucked in the queue that keeps groving in size.

So to my questions.

Should I even try to change the default pm.* settings or are they fine? In the php-fpm pool conf file I can read “The below defaults are based on a server without much resources. Don’t
; forget to tweak pm.* to fit your needs.”.

How can I get my servers to use more than 1.8 GB memory?

It feels like i’m missing something obvious…

Regards,
Tomas