PHP Fatal error: Uncaught exception 'Exception' with message 'The configuration file {/home/admin/web/domain.com/public_html/config/config.ini.php


#1

Every time I try to install Piwik, I get the ‘500’ Tracker Status - GET request to piwik.php failed.

I looked at the logs and I am getting this long error message.

[quote="[Sun Oct 18 15:12:19 2015] [error] [client 208.58.] PHP Fatal error: Uncaught exception ‘Exception’ with message ‘The configuration file {/home/admin/web/tracking.domain.com/public_html/config/config.ini.php} has not been found or could not be read.’ in /home/admin/web/tracking.domain.com/public_html/core/Application/Kernel/EnvironmentValidator.php:64\nStack trace:\n#0 /home/admin/web/tracking.domain.com/public_html/core/Application/Kernel/EnvironmentValidator.php(45): Piwik\\Application\\Kernel\\EnvironmentValidator->checkConfigFileExists(’/home/admin/web…’, false)\n#1 /home/admin/web/tracking.domain.com/public_html/core/Application/Environment.php(185): Piwik\\Application\\Kernel\\EnvironmentValidator->validate()\n#2 /home/admin/web/tracking.domain.com/public_html/core/Application/Environment.php(94): Piwik\\Application\\Environment->validateEnvironment()\n#3 /home/admin/web/tracking.domain.com/public_html/piwik.php(56): Piwik\\Application\\Environment->init()\n#4 {main}\n thrown in /home/admin/web/tracking.domain.com/public_html/core/Application/Kernel/EnvironmentValidator.php on line 64, referer: http://tracking.domain.com/"]

[/quote]

I turned off NGINX proxy support - same thing.
I had this exact set-up months ago, and Piwik worked GREAT!
But then I switched VPS providers, installed CentOS and VestaCP, and now getting this error message.


#2

I suspect that you haven’t set the “/config” directory to be world-writable. The “/tmp” directory needs to be world-writable too.

Once Piwik has been configured, you can reset the “/config” directory to read-only.

I hope this helps.


#3

So I tried that, but it did not work. :frowning:

In VestaCP, I selected a different ‘php’ file which fixed it.

I’m not sure how it works, but you can set different php parameters to each site.