Persistent installation error


#1

This is so frustrating. I tried to install the Piwik a dozen times, and every-time I get the same error. I downloaded the most recent version of Piwik, extracted it, and uploaded to my website (the root of the zip, with the 2 xml files I uploaded to the root , and everything contained in the PIWIK directory into a directory with the same name on my server).

Please note that I have my hosting with Godaddy. I have MySQL set-up and have a PHP version of 5.x. I have a windows server and IIS 7.0.

Every time I go to mydomain.com/piwik I get the following error:

Piwik couldn’t write to some directories.

Try to Execute the following commands on your Linux server:

cacls XXXX\html\piwik/tmp/templates_c/ /t /g Iusr_4613936:f
cacls XXXX\piwik/tmp/cache/ /t /g Iusr_4613936:f
cacls XXXXl\piwik/tmp/assets/ /t /g Iusr_4613936:f
If this doesn’t work, you can try to create the directories with your FTP software, and set the CHMOD to 0777 (with your FTP software, right click on the directories, permissions).

After applying the modifications, you can refresh the page.

If you need more help, try Piwik.org.

Any ideas?


(vipsoft) #2

Ignore the fact that it says “Linux”. Are you able to run “cacls”? If not, can you use the Web Platform Installer (e.g., “Web PI” on http://php.iis.net/ ) or any of the other IIS web app deployment tools?


#3

For the sake of future Piwik users - this is what I had to do to get it working. After uploading the Piwik to the server, I opened the Godaddy’s file manager, selected the directory and chose file permissions - and set them to write.

Vipsoft: thanks anyway.


(Abby Knight) #4

When you say you set the permissions to write did you set all “owner”, “group” and “public” and also was it the root that you altered the permissions.
thanks.