PDO extension error after 0.2.37 upgrade


(qwicfingers) #1

After an auto upgrade to 0.2.37 I’m receiving the following error. Does anyone have any idea of how to fix this?

The PDO extension is required for this adapter but not loaded

Backtrace:
#0 /home/…/piwik/libs/Zend/Db/Adapter/Abstract.php(228): Zend_Db_Adapter_Pdo_Abstract->_connect()
#1 /home/…/piwik/core/Piwik.php(1212): Zend_Db_Adapter_Abstract->getConnection()
#2 /home/…/piwik/core/FrontController.php(230): Piwik::createDatabaseObject()
#3 /home/…/piwik/index.php(52): Piwik_FrontController->init()
#4 {main}

PDO is enabled

PDO Driver for MySQL, client library version 5.0.75


(qwicfingers) #2

Fixed by copying my php.ini form my root folder to my piwik folder… not sure why this would make a difference.