PDO Erweiterung


(Anotherstyler) #1

Hallo,

ich bin zwar nicht besonders zuversichtlich, aber vielleicht gibt es ja doch irgendeine Möglichkeit. Würde gerne auf unserem Uni-Server Piwik einsetzten, aber bei der Installation bekomme ich eine Fehlermeldung:

Piwik erfordert entweder die mysqli Erweiterung oder die PDO und pdo_mysql Erweiterung.
PDO ist glaube ich vorhanden, pdo_mysql aber nicht

Sie müssen PHP mit “iconv” Unterstützung konfigurieren und neu übersetzen, --with-iconv.

Kann ich da was machen? Gibt es Alternativen?

Vielen Dank

Christian


(Belgeron) #2

Wenn es auf einem Uni Server läuft und du nicht der Admin bist, wirds da glaube ich schwer werden nachträglich PDO_MYSQL drauf zu bekommen.

Du kannst es aber mit <?php phpinfo(); ?> anziegen lassen was installiert ist. Klappts denn vielleicht mit mysqli ? Ich benutzt für meine installationen auch überall mysqli anstatt pdo.