Pb after update


(mtgt) #1

Hi,

I got an error after updating to last version 0.2.28

The language selected ('') is not a valid language file 

Backtrace:

#0 /homepages/1/d145326492/htdocs/stats/core/Translate.php(43): Piwik_Translate->getLanguageToLoad()
#1 /homepages/1/d145326492/htdocs/stats/core/FrontController.php(236): Piwik_Translate->loadUserTranslation()
#2 /homepages/1/d145326492/htdocs/stats/index.php(51): Piwik_FrontController->init()
#3 {main}

Any help will be really appreciate. Here is the URL
Before this update, everything worked well!!

Thanks in advance for your help!
Greg


(michaelc) #2

Hi,

You might be having problems with your configuration file.

Please double check the ‘global.ini.php’ file in the ‘piwik/config’ location. Please check the following section:

[Language]
current = en
fallback = en


(mtgt) #3

Hi, thanks to reply !

I check these code in piwik/config

There are no problem with them!

Thanks again for your help!


(mtgt) #4

Hi,

If nobody have an answer or an idea for me; I have another question. Is it possible to install Piwik 0.2.28 with my database from my old version of Piwik? It’s just to save some data already stored.

Thanks in advance for your support.

Greg


(Matthieu Aubry) #5

language entry has changed in the config file.

Please check that

[General]
default_language = en

is set properly


(mtgt) #6

[quote=matthieu @ Feb 9 2009, 02:07 AM]language entry has changed in the config file.

Please check that

[General]
default_language = en

is set properly[/quote]

I check into config folder the file config.ini.php
Nothing about language
I add

[General]
default_language = en

but nothing more, it still not working.
Here is my error

Backtrace:

#0 /homepages/1/d145326492/htdocs/stats/plugins/PluginsAdmin/PluginsAdmin.php(28): Piwik_Translate('PluginsAdmin_Me...')
#1 /homepages/1/d145326492/htdocs/stats/core/PluginsManager.php(170): Piwik_PluginsAdmin->postLoad()
#2 /homepages/1/d145326492/htdocs/stats/core/FrontController.php(238): Piwik_PluginsManager->postLoadPlugins()
#3 /homepages/1/d145326492/htdocs/stats/index.php(51): Piwik_FrontController->init()
#4 {main}

If you want check, This the URL

Thanks again for your help

Greg


(pebosi) #7

check “global.ini.php” for that content:

; if you want all your users to use Piwik in only one language, disable the LanguagesManager
; plugin, and set this default_language (users won't see the language drop down) 
default_language = en

regards


(Matthieu Aubry) #8

see faq http://piwik.org/faq/update/#faq_6


(mtgt) #9

Hi,

Thanks Matthieu.
I follow the FAQ. I get some error, I download the default “global.ini.php” and I upload to replace my one.
After that everything work fine. Exept this small red cross, like a missing picture in the bottom of my website. If you click on, you go to Piwik. Before this update I never get that ! Is it normal or there are something to do?
If you want see it on my web site

Thanks again for your help