Page url not defined from version 1.6


#1

Hey everyone,

I have a personal piwik installation serving 5 websites, from custom django projects and simple html pages to wordpress installations. Since version 1.6 I get on all of them “Page url not defined” when I check the “Actions” tab. On version 1.5.2 everything was normal and on 1.7-b7 I still get the same error.

Is there an option I should be aware of or is it a known bug?

Thank you in advance,
Giorgos


(vipsoft) #2

I believe there was some filtering added in 1.6. Actions that don’t look like URLs (i.e., start with http://, https://, ftp://, or news:// are filtered and treated as unspecified.) Are you using piwik.js or PiwikTracker?


#3

Hey vipsoft,

thanks for the answer. I’m using the


(Nimitz1061) #4

I am seeing this same issue on a brand new 1.6 installation. Testing with browsers set to specifically allow javascript access to the url does not change the behavior.


(Matthieu Aubry) #5

If you use Firebug, what is the FULL url sent (starting with piwik.php?.. ) ?


(Nimitz1061) #6

Don’t really use firebug per se.

What I have figured out is this:

We installed piwik in a folder on an existing domain. The parent web root folder has an htaccess file in it which includes a rule to force all accesses to that domain to use https protocol.

All HTTP accesses on the monitored sites were failing to define the page url. HTTPS accesses on the other hand, worked.

So - I’ve forced mod rewrite off in the Piwik installation folder - and are now getting page url’s defined.

The so-called SEO url rewrites on some of my test sites are playing havoc with Piwiks “category handling”, but thats another issue…

This phenomenon is probably worth adding to the FAQ entry for url not defined…

David


(Matthieu Aubry) #7

Thanks for the suggestion I updated the page url not defined faq


(Nimitz1061) #8

You’re welcome. Its nice for folks to not have to bang their heads against known issues, so I’m happy to help. :slight_smile:

David


(Nimitz1061) #9

I should add that while I’m not a Javascript developer, I’m informed that recent browser updates include engines that have been modified to NOT share current URL data across security contexts. This problem may be related to those changes rather than any web server bug…

David


#10

There was an http to https automatic redirection in my case also. Enforcing https usage by replacing the line

var pkBaseURL = ((“https:” == document.location.protocol) ? “xxx” : “xxxx”

with a string directly pointing to my installation using an https link does the trick!

Thanks everybody for the responses :wink:

Best,
Giorgos