Page Overlay feature


(Tassoman) #1

Does anyone have a working “Page Overlay” in its Piwik installation?
I can’t get it working neither with a plain Piwik installation on a simple HMTL website.
The worst thing is neither Page Overlay on http://demo.piwik.org is working. ::o
Please post an example screenshot of a working copy if you have one.


#2

For me it didn’t work until my domain matched Piwik’s.

So we had to create a “stats.my.domain.com” matching our real site “www.my.domain.com”.

If I use our internal http://stats.intranet/ then Overlay will not work for me.

Dali


(Tassoman) #3

Well I’ve did some more testing on this.

I’ve set my piwik installation in vmdev.local/piwik , then I’ve monitored vmdev.local/test/dummy/* pages. Overlay feature was working. It worked also if an old jquery (1.4.4) was loaded into dummy pages.

But the feature stops working correctly if I “move” (just a 3rd level domain aliasing) Piwik installation to stats.vmdev.local/piwik. it happens the right frame is stuck in “loading…” and doesn’t show any counts however href baloons still there on the right frame hovering the dummy website.

Any hint?


(Matthieu Aubry) #4

But the feature stops working correctly if I “move” (just a 3rd level domain aliasing) Piwik installation to stats.vmdev.local/piwik

The URL stats.vmdev.local/piwik looks the same in both cases.

Maybe you could write the bug report as such

  • What were the inputs / URLs / setup
  • What I got
  • What i expected to see

If you find a bug the best will be then that we create an issue on github.


(Tassoman) #5

I’ve filed issue # 6122 on GitHub about this. (:smiley: