Outlinks not tracked after upgrade to 1.11.1

No outlinks are being tracked since we upgraded Piwik from 1.10.1 to 1.11 and then 1.11.1.

We force tracking of outlinks with the onclick event because automatic tracked never worked well in out sites. Our code:

Visit RemoteSite

Do I need to migrate to asynchronous tracking or something?

What tracking code are you using? If you use asynchronous tracking you also need to use a sync link tracking.

We are using the non-asynchronous tracking code, thanks.

Make sure the piwik tracking code is just after opening tag

The tracking code is just before . Everything was working fine until we upgraded Piwik, so the problem shouldn’t be related with the page, unless piwik.js has changed between 1.10.1 and 1.11.1.


I’ve made some reseach with Firebug and I can see the page is calling piwik.php “well”. I also reviewed our Nginx logs and I can see the ‘visit’ tracking calls, so Piwik IS receiving these actions. I’ve checked our mysql just in case any table was corrupted but everything seems ok.

Sorry works for us on the demo, so not sure the problem, do you see any javascript error on the site ?

Is it possible your nginx config is tracking the js via fast-cgi instead of nginx directly?


Also did you have to change any piwik folder permissions on v 1.10.1 that in later versions were slightly different?

According to the REST api documentation, We should pass a parameter called “outlink”, but using Firebug I see the parameter passed is really “link”. Is it right?

Problem solved. Someone added a second pixel to our site, the very same day we upgraded Piwik. It was using same javascript code, so overwriting the first piwik object. Outlinks were being tracked on that second id site. Thanks for your help and excuse me for making you loose time trying to help me :frowning:

No worries, glad to hear it’s working now!