Opt-Out-Häkchen lässt sich nicht ausschalten


#1

Hallo,

ich habe seit einiger Zeit das Piwik Custom-Opt-Out in die Datenschutzerklärung meiner Website eingebunden. Das hat immer gut funktionert, das Häkchen ein- und auszutragen, je nachdem, ob man der Piwik Analyse zustimmt oder nicht. Nun aber (und ich kann nicht genau sagen, seit wann) lässt sich das Häkchen nicht mehr deaktivieren. Das Häkchen ist standardmäßig gesetzt, beim Abwählen lädt die Seite ein wenig, um den Haken gleich wieder zu setzen. Weiß hier jemand Abhilfe? Ich habe 2.9.1 in Verwendung gehabt und nun mal probeweise auf den jüngsten RC geupdated - unverändert. Das Ganze ist insofern heikel und zeitkritisch, weil die Abwahlmöglichkeit ja eine gesetzliche Vorgabe in Deutschland ist. Es wäre schlecht, wenn Abmahnwillige merken würden, dass das Opt-Out nicht funktioniert, deshalb möchte ich diese Lücke möglichst bald schließen (möglichst noch vor Weihnachten, wenngleich dies recht knapp ist, aber wer weiß).

Danke einstweilen für Vorschläge und beste Grüße,
Fatuhiva


(Stefan Giehl) #2

Kannst du mir mal die URL deiner Seite schicken. Gerne auch als PM. Dann kann ich mir das mal näher ansehen.
Mir sind hier derzeit sonst keine Probleme bekannt.


#3

das problem hatte ich auch. es lag bei mir daran, dass wenn ich firefox nutze und cookies von drittanbietern verboten habe. piwik konnte dann kein cookie setzten. piwik setzt dieses cookie um den user dann nicht mitzuzählen.


#4

Danke für den Hinweis - bei mir reagieren alle Browser (FF, Explorer, Chrome, Safari, Opera) gleich und ignorieren das Opt-Out. Cookies von Drittanbietern sind erlaubt, ändert leider nichts …


#5

Danke SteveG,

das war der entscheidende Hinweis - ich hatte den Iframe mit der URL ohne www. eingebunden, während die Website unter www. läuft (war bis vor einiger Zeit anders). Nun mit der korrekten URL klappt alles mit dem Opt-Out wieder wie gewohnt. Nochmals danke für die kurzfristige Hilfe am Weihnachtstag,

Fatuhiva