No websites, no usermenu after update


(Gregor) #1

Hi there,

after update from 1.5.1 to 2.10.0 I don’t get a usermen in the upper right, and in Settings “Websites” and “All Website” I get a blank page.

I tried:

  • resetting Update and run it again from condole
  • uploading all files via ftp
  • manipulating the site and user tables (deleting and adding via phpmyadmin)

System Check states " Huzzah! There are no problems with your Piwik setup. Give yourself a pat on the back." :slight_smile:

But there is a problem? Any ideas?

Regards, Gregor


(Matthieu Aubry) #2

Hi there,

Please check this FAQ: How do I configure my server to let Piwik serve HTML files? - Analytics Platform - Matomo


(Gregor) #3

Thx, that fixed it: I had a Mod Rewrite in an upper directory that I had to disable :slight_smile:

Thx a lot for your help and your great work!

Regards Gregor


(Gregor) #4

Aaah, one more issue: In the settings section, no Websites are displayed.

I tried:

  • Rewrite Engine Off for PIWIK folder.
  • Setting 0755 for all folders an files in the plugins Section
  • plugins/MultiSites/angularjs/dashboard/dashboard.directive.html gives the expected result (which it didn’t, before shutting off the ModRewrite in htaccess).

Any hints?


(Matthieu Aubry) #5

Do you see any error in the browser console maybe?


(Gregor) #6

No, nothing, no errors no warnings. Really strange.

I can add sites, they appear in the database and the all Websites menu. But nothing changes in that admin table.

Regards, Gregor


(Chris) #7

Hello Gregor,

is it a german site with “Umlauten”?

Maybe this helps:

http://forum.piwik.org/read.php?2,120225


(Gregor) #8

Hello Chris,

YES :slight_smile:

Adding “charset = utf8” in the database-section did the trick.

Thx a lot!

Regards, Gregor