No more tracking after manual update to 1.2


(Curu) #1

Hello

Since the auto-update didn’t work for 1.1 and 1.2 (I had a php error, UNzip class missing), I manually updated from 1.0.x to 1.2 and since then the tracking for all the sites configured has stopped.

Does anyone know what can be the problem?

Thanks


#2

I’m also having the same problem. I had an error during the auto update and so ended up doing a manual upgrade to fix the error but now I have no user tracking.


#3

I too manually updated to 1.2 (did not tried auto-update). Since then no new visitors are tracked, only returning visitors are. I ran the database update from command line.
No entry for new visitors is added to the _log_visit table.


#4

Tom - I’ve noticed this as well, only returning visitors are being recorded.

There must be a setting/procedure somewhere to get them back, unless it’s something to do with the new cookie?


#5

I think I found something:

In core/Tracker/Visit.php line 437 is

‘visitor_returning’ => $visitCount > 1 || $this->isVisitorKnown(),

but should be

‘visitor_returning’ => ($visitCount > 1 || $this->isVisitorKnown()) ? 1 : 0,

otherwhise it tries inserting ‘false’ as an integer, which will fail.

Still gettting this:

Error query: SQLSTATE[HY000]: General error: 1032 Can’t find record in ‘piwik_log_profiling’ In query: INSERT INTO piwik_log_profiling (query,count,sum_time_ms) VALUES (?,1,0.44) ON DUPLICATE KEY UPDATE count=count+1,sum_time_ms=sum_time_ms+0.44 Parameters: array ( 0 => 'SELECT idaction, type FROM piwik_log_action WHERE ( hash = CRC32(?) AND name = ? AND type = ? ) OR ( hash = CRC32(?) AND name = ? AND type = ? ) ',)

Don’t know if it is important somehow?


#6

I don’t know enough about PHP to work out the problem. The database side of the upgrade seemed to pass without any problems, but maybe the original error involving a SQL error regarding a missing/invalid column (same error reported on the other recent threads) caused a corruption in the database.

I’m hoping I don’t have to roll this back to 1.1 and lose a days stats.


(Curu) #7

For my part, it doesn’t seem that returning visitors are recorded.


#8

Has anybody had any luck with a solution? We are having the same problem with new visitors not being counted.


#9

Tried a fresh install from scratch with a new DB and added the tracking code the website that’s being tracked.

Everything installed fine, but still have the same issue - no new users are being recorded, only my return visit to the site shows up in the log.

Next step is to go back to 1.1.1, test again and if that works stick with that until someone can shed some light on this problem.


#10

It’s a bug. You need to modify core/Tracker/Visit.php.

Around line 437 you find

‘visitor_returning’ => $visitCount > 1 || $this->isVisitorKnown(),

which should be

‘visitor_returning’ => ($visitCount > 1 || $this->isVisitorKnown()) ? 1 : 0,

After that change it is working, at least for me.


#11

We also have the same problem. After a smooth auto_update from the command line, no more visits are being tracked.


#12

Has there been any official notification/acknowledgement that this is a bug with 1.2? I find it strange that not everyone appears to be having the same issue.

Tom - That fix seems to be working, I’ll keep an eye on it over next couple of days just to make sure.

Many thanks!


(vipsoft) #13

AFAIK this is a regression issue introduced in MySQL 5.5. This has already been fixed in trunk. We will advise when we have an ETA on the next release.


#14

I’m running MySQL 5.0…


#15

And I’m running MySQL 5.1.x…


(Curu) #16

So do I (i.e not in 5.5)


#17

We currently use MySQL 5.1.41-3ubuntu12.10


(vipsoft) #18

Sorry, looks like it’s a strict mode issue. Julien fixed this in trunk and it’s the same as Tom’s fix. http://dev.piwik.org/trac/changeset/4052