No entry or class found for 'path.misc.user'

I just installed the new update (3.12.0) and now i’m getting an error when I open my analytics.
The error is: "No entry or class found for ‘path.misc.user’ "
How could I solve this problem?
The folder /misc/user seems to be normal, with a few images and a html file.

Thanks in regard


I’m pretty clueless on why this happens, but can you please look into your config/global.php

There should be a line containing path.misc.user in the 13. line.

That line was missing… (I have no clue why)
But after adding that line everything works fine again.

1 Like

I have a similar problem after auto updating to v 3.1.2

My global.php row 11 and 13+14 looks like this:

'path.root' => PIWIK_USER_PATH,

'path.tmp' => function (ContainerInterface $c) {
        $root = $c->get('path.root');

I tried adding

    'path.misc.user' => 'misc/user/',

to row 13 but didn’t solve. Also row looks different in my global.php. Not sure why that is.

I tried copying your rows 11 and 13, but received an error 500. Any ideas what went wrong during the update and how to make matomor run again?

Thanks in advance!

I would recommend replacing the whole file with the correct one from the latest zip to get Matomo to run again and then use the integrity checker to find other corrupted files.

Is it possible that your webserver limits the time a PHP script can take and the update got aborted by the PHP in the middle?

Thanks for your reply.
It might be that the server limited the time. I will ask my hosting provider.

I tried updating manually by adding the new matomo version via FTP in binary mode and replacing the old files. Now nothing works anymore.
Main goal now is to not lose the tracking data. Is there any file/folder I can backup to keep the tracking data?

As long as you don’t loose the database, you don’t loose any data. Even if you don’t have the config.ini.php anymore, you can go through the installer, enter the mysql details of the existing database and it will detect that Matomo is already installed there.

See also Update Piwik User Guide - Analytics Platform - Matomo

I will try to completly reinstall as you suggested. Thanks for your support, Lukas.