No data in this category. Try to "Include all population"


#1

Hallo,
I need some help. I’ve got piwik 1.6 installed and I got the table from the module actions that shows exit pages in a custom plugin.
When I open the subtables of the page I now and then get the error message
No data in this category. Try to “Include all population”.

Some guy in the German forum has the same problem and there was a bug wis a fix with the same name, but this was some years ago.

Does anybody now how to solve this?
Thanks
Davud


(Matthieu Aubry) #2

Does it have this bug only for “today” or also for other dates?


#3

It definitly apears with “month”, but because the issue seems to apear by random I can’t say that it doesn’t apear for the other dates.


(hightechguy) #4

Same issue here…
Data is being displayed by month

H.


#5

I have same problem with outlinks module.

how to dissolve this problem. Before upgrade I haven’t problem like this and now I use 1.9.1 version, we can’t track on outlinks module.

#0 Piwik_ErrorHandler(…) called at [/home2/xxxx/public_html/xxxxx/piwik/tmp/templates_c/%%41^416^416F4DD8%%datatable_actions_subdatable.tpl.php:12]
#1 include(…) called at [/home2/xxxxxx/public_html/xxxxx/piwik/libs/Smarty/Smarty.class.php:1263]
#2 Smarty->fetch(…) called at [/home2/xxxx/public_html/xxxxxx/piwik/core/View.php:133]
#3 Piwik_View->render(…) called at [/home2/xxxxx/public_html/xxxxx/piwik/core/Controller.php:153]
#4 Piwik_Controller->renderView(…) called at [/home2/xxxxx/public_html/xxxxxx/piwik/plugins/Actions/Controller.php:375]
#5 Piwik_Actions_Controller->getOutlinksSubDataTable(…) called at [:]
#6 call_user_func_array(…) called at [/home2/xxxxx/public_html/xxxxxx/piwik/core/FrontController.php:138]
#7 Piwik_FrontController->dispatch(…) called at [/home2/xxxx/public_html/xxxxxxx/piwik/index.php:53]

">No data in this category. Try to “Include all population”


(Matthieu Aubry) #6

please upgrade to latest beta which fixes problem: http://builds.piwik.org/piwik-1.9.2-b3.zip


#7

Now I use Piwik 1.9.2-b3 is work fine and dissolve my problem.


#8

Hello,

I am currently using 2.8.3 piwik Version and am facing the same problem. This issue is random. Any solution for this?

Regards.


(Matthieu Aubry) #9

Hi there,

can you upgrade to 2.12.0 and confirm whether you still have the issue? If you still have issue in 2.12.0 please create a bug repor with screenshot and steps to reproduce at: Issues · matomo-org/piwik · GitHub - we will look into it


#10

Hi

I am also getting this error. Attaching a screenshot for the same. What I noticed is that this happens when ever I select a larger date range.
I use the latest piwik version - 2.12.1.


(Matthieu Aubry) #11

Hi @Arun

please feel free to create a bug report at: Issues · matomo-org/piwik · GitHub


#12

Thanks Matt.

I created a bug report here - Error: No data in this category. Try to "Include all population" · Issue #7811 · matomo-org/piwik · GitHub

Thanks
Arun