No "Accept invitation" page when new created user receives email (Matomo 4.11.0)

Hello. We want to migrate to Matomo 4.11.0 and installed 4.11.0 on our development stage. Problem case: I invite a user. The user gets an email. But: when I click “Accept Invite” in the email I am forwarded to the Matomo login page. From your page “https://matomo.org/faq/general/manage-users/” I expect that the user gets a “Accept invitation” page (see screenshots). This is not coming. Because this page is not coming that user cannot set his passwort and the login is not possible.

Do you have an idea why we don’t get the “Accept invitation” page?

grafik

@innocraft , did you ever this kind of behaviour?

Hi @OliverKoch, so just to confirm the desired new users is getting that email as per your screenshot, are they then setting a password before clicking accept? Once they click accept and are redirected to the Matomo Login screen, what occurs when they input these credentials? Also what do you see for this new user under Admin >> System >> Users ?

Hi @V.K :

  1. I invite a new user,
  2. The user gets an email in which he can accept or decline the invitation
  3. It doesn’t matter which of the two links the user clicks, in both cases the next page is the Matomo Login page. We don’t get the “Accept invitation” page in which the user can set the password.
  4. The user account got created, I can see it in the user list. It looks normal, the rights I added are shown.
  5. When I try to log in with the new user on the Matomo Login page different things happen:
    a) I just put in the name, but no password: Matomo says “password needed”
    b) I put in the name and a weak password like “abc”: Matomo says “This password is too weak”
    c) I put in the name and a strong password: Matomo says, that the combination from username and password is not correct

So it seems nobody has an idea why we have this problem or how we could fix it? Then I will ask our hosting company to go back to 4.8.0 because this problem blocks our system for new users. Too sad.

@OliverKoch Sorry for the delay, this is not expected behavior. I was trying to recreate this issue but was unable too. Could you please advise me of the following:

  • Matomo Version: 4.11.0
  • PHP Version:
  • Server Operating System:
  • Additionally installed plugins:
  • Browser:
  • Operating System:
Matomo Version: 4.11.0
PHP Version: 8.1.8
Server Operating System: Linux
Additionally installed plugins: all core plugins activated (GeoIP2 & MobileMessaging deactivated) + CustomVariables (v4.1.1), LogViewer (v4.1.1), Provider (v4.0.4), MarketingCampaignsReporting (v4.1.3)

Browser: Firefox 91.11.0 & 104.0.2 (Win 10), Edge 104.0.1293.70 (Win 10), Safari on iPhone 12 with iOS 15.6.1
Operating System: Win 10, iOS 15.6.1 on iPhone 12

Is it possibile that it is a configuration problem? We have the parameter “login_allow_logme” set to 1. Could this be a problem? And another thing: our system is based on a pre Piwik 3.8 installation and we always update the system (4.8.0,4.5.0,4.4.1,4.3.1,4.3.0-b3,4.1.1)

It could potentially be configuration related.

Are you able to change this to ‘0’ and try again and let me know if it works? If not please revert this to ‘1’ and I will raise this issue as a GitHub issue.

We have the same problem on two different systems. We changed the parameter on one system to “0”, but this didn’t solve the problem.
Maybe we have to setup one environment completely new from the scratch with a version 4.11.0, check if it works and then change parameters until we find the problem.