New Matomo installation stopped tracking Firefox

I just installed matomo a few days ago on a shared hosting service for my webpage. It worked great first, tracking all visits as far as I could tell, including my own visits through Firefox.

Then I had a problem with too many requests being sent when I logged into matomo which caused both error messages within matomo and that the server blocked my ip for a few minutes. The server support fixed this and at the same time I changed matomo adress from to

Thereafter I notice that matomo don’t track firefox users. It’s strange as it did track firefox when I first installed it.

I’ve tried with a fresh matomo installation, all clean with a new database and still the same thing.
I’ve tried with enabling tracking even for browsers with “Do Not Track” turned on.
I’ve tried cleaning my Firefox cache and cookies for this site and enabling tracking for this site in Firefox and turning off all adblock extensions for it.

Still, it doesn’t show in Matomo when I visit the site from Firefox browser.
If I use Chrome or Safari from same mobile and desktop, they show up.

I’m wondering if something could be wrong with my setup/installation? And if perhaps there are other browsers not getting tracked.

Can you see the HTTP requests from FF to Matomo?
Is there any error on them?
Check with F12, then network tab…

Also how do you track? (just JavaScript code, MTM, HTTP API, etc.?)

1 Like

Great, looking in the web developer network tab shows that a recently installed plugin (ClearURLs) blocks access to Matomo. When I disable ClearURLs, Matomo tracks this browser too. Guess that’s it! And guess it shouldn’t interfere with other browsers!

Thanks @heurteph-ei :slightly_smiling_face: