New install of 2.0.3 not recording page views


#1

Hi,

I’ve just installed 2.0.3 on my localhost website (a static html website) and the installation went through without a hitch.

I’ve cut and paste the tracking code into a footer file yet no tracking occurs. All reports on the dashboard are empty.

I created a new html page with just the tracking code, so literally

And this didn’t work.

Having read some other posts with a similar issue I enabled debugging inside piwik.php

The debug message is

Debug enabled - Input parameters:
array ( ‘idsite’ => ‘1’, )
Loading plugins: { Provider,Goals,PrivacyManager,UserCountry,Login,UsersManager,SitesManager }
Current datetime: 2014-03-04 19:46:42
GET parameter rec not found in URL, request excluded
’rec’ parameter not found.
Visitor excluded.
-> Scheduled tasks not triggered.
Next run will be from: 2014-03-04 20:19:57 UTC
Nothing to notice => default behaviour
End of the page.

when I browse to the new page with just the tracking code.

I dug into the php code and found the parameter message inside VisitExcluded.php at line 67.

The comments above the code

    [i]/*
     * Requests built with piwik.js will contain a rec=1 parameter. This is used as
     * an indication that the request is made by a JS enabled device. By default, Piwik
     * doesn't track non-JS visitors.
     */[/i]

imply that this parameter (rec) is missing on non-JS visitors.

JS is enabled on my desktop.

Any help on this?

John


(Matthieu Aubry) #2

see How do I enable tracking for visitors that have disabled Javascript? - Analytics Platform - Matomo


#3

Hi Matt,

Thanks for that. However I’m not sure if that helps me as I have JS enabled.

I did add the noscript code to see if anything happens but I still get the debug message in my initial post.

Just to re-iterate, my problem is with JS enabled visitors. Piwik does not seem to add in the rec=1 parameter as suggested by the code comments.

Cheers John


(Matthieu Aubry) #4

your original post is the output you get when looking at the request