New 1.2.1 installation, tracker set, but no stats


#1

Hello,
everything is in the subject.

How can I get the incoming stats in Piwik ? Do I have to wait ? How long ?

No records in log_visit table. The tracker code looks fine.

I followed the FAQ “Piwik doesn’t track any visits and pages, and shows “No Data” in all reports.” but it still does not work.


(Matthieu Aubry) #2

enable DEBUG as explained at the bottom of: Tracking API - Analytics Platform - Matomo

Then post here your site URL


(NetThinks) #3

I have the same problem, debugging enabled:

http://www.sbs-feintechnik.com/


#4

Hello,
I work on my localhost.

My site URL is :
http://intranet-laforet.local/index.php/intranet_site/

Here is the request sent to piwik.php :
http://intranet-laforet.local/piwik/piwik.php?idsite=1&url=http%3A%2F%2Fintranet-laforet.local%2Findex.php%2Fintranet_site%2F%2F&res=1920x1080&h=9&m=56&s=47&cookie=1&urlref=&rand=0.5893999751650797&dir=0&fla=1&pdf=1&realp=0&wma=1&action_name=

Here is the debug output :
Input parameters:
array ( ‘idsite’ => ‘1’, ‘url’ => ‘http://intranet-laforet.local/index.php/intranet_site//’, ‘res’ => ‘1920x1080’, ‘h’ => ‘9’, ‘m’ => ‘56’, ‘s’ => ‘47’, ‘cookie’ => ‘1’, ‘urlref’ => ‘’, ‘rand’ => ‘0.5893999751650797’, ‘dir’ => ‘0’, ‘fla’ => ‘1’, ‘pdf’ => ‘1’, ‘realp’ => ‘0’, ‘wma’ => ‘1’, ‘action_name’ => ‘’, )
Loading plugins: { Provider,Goals }
Current datetime: 2011-04-01 08:21:01
GET parameter rec not found in URL, request excluded
Visitor excluded.
-> Scheduled tasks not triggered.
Next run will be from: 2011-04-01 08:56:08 UTC
Nothing to notice => default behaviour
End of the page.

array (
‘piwik_auth’ => ‘login=czo1OiJhZG1pbiI7:token_auth=czozMjoiMWJhMmIzM2NjMjI0MTE2ZjVlNjAwMmE2NjJjYzUxYjgiOw==:_=c33dd3f7ca05e89790a454522bd84ebd3b539fa8’,
‘adminNavigationTab’ => ‘preview’,
‘eZSESSIDc645a90703f17bc4444874f2bdc5fcd5’ => ‘0e1b29e73621163085b1cc9249fab739’,
‘eZSESSID85ce07992a0881ce36508c44d3490c9e’ => ‘573e73cd0cc70fd6523faf005bcd5336’,
‘ezcst_unfolded_node_list’ => ‘n1,n5,n166,n2,n157,n811971,n158,n216,n8409,n12684,n2097,n414224’,
‘PIWIK_SESSID’ => ‘5f283098ec7704436927d6c59c0798a8’,
‘is_logged_in’ => ‘true’,
)

Time elapsed: 0.022s


(Matthieu Aubry) #5

@Franck, somehow the request is missing the parameter &rec=1
I think you are maybe using an old version of piwik.js ?

@NetThinks interesting, see at: Seite nicht gefunden

Warning: pack() has been disabled for security reasons in /srv/www/sbs-feintechnik.com/www2/htdocs/statistik/plugins/AnonymizeIP/AnonymizeIP.php on line 52

please ask your provider to enable this function. We will check for it in the next version of Piwik to make sure it is told during install: Installer to check for pack() function available · Issue #2246 · matomo-org/matomo · GitHub


#6

Indeed, the “rec=1” parameter is missing. if I add it manually at the end of the request, it writes in log_visit and I do get 1 visit on the dashboard.

I downloaded the latest version of Piwik (1.2.1) yesterday, from the official website.

What’s wrong with the script ? I tried the non-minified version but no change.


#7

Ok, I found out the problem. It’s stupid, sorry.

Piwik was already installed on the website. And there were two piwik.js included in the page. And the first one seems to be an older version.


#8

Moin :wink:

I have the same problem :frowning:

on the first installation auf Version 1.2.1 with disabled AnonymizeIP.

The adress: .clauss.east.de

Thanks for your Help…

Jan


(Matthieu Aubry) #9

@Jan06132 enable DEBUG as explained at the bottom of: Tracking API - Analytics Platform - Matomo


#10

$GLOBALS[‘PIWIK_TRACKER_DEBUG’] is “true”.
$GLOBALS[‘PIWIK_TRACKER_DEBUG_FORCE_SCHEDULED_TASKS’] is false - correct?

The http-Request of the “Downloads”-Page of this site is

http://www.clauss.east.de/ausw/piwik/piwik.php?action_name=Downloads&idsite=1&rec=1&rand=0.836583327264303&h=21&m=22&s=24&url=http%3A%2F%2Fclauss.east.de%2Fdownload%2Findex.php&urlref=http%3A%2F%2Fclauss.east.de%2F&_id=49f3c1e13b739951&_idts=1301943670&_idvc=1&_idn=0&_ref=&_refts=0&_viewts=1301943670&pdf=1&qt=0&realp=0&wma=1&dir=0&fla=1&java=0&gears=0&ag=0&res=1024x768&cookie=1

I have not idea what this says me :wink:


(Matthieu Aubry) #11

I get: Firefox can’t find the server at www.clauss.east.de.


#12

Thanks for your time

I have test the server at 10:00 from 2 networks. -> OK
If this problem reproducible then send me please the IP of your DNS-Server.

You can also use www.clauss-halle.de

Thanks
Jan


(Matthieu Aubry) #13

Can you please upgrade to latest RC 301 Moved Permanently

I suspect you have changed some settings in the config file? it looks like tracking is working on clauss-halle.de ?


#14

Ok, i upgrade it at the weekend. My Internetconnection at work is very slow (Handy).

The configfile is only change from the installation-script.

Thanks


#15

Moin :wink:

I have clean the website before i install the piwik_1.5.2_rc6 on the System.

The effect is the same :frowning:

The http-Request:

http://www.clauss.east.de/ausw/piwik/piwik.php?action_name=Downloads&idsite=1&rec=1&rand=0.8816145627605063&h=14&m=35&s=22&url=http%3A%2F%2Fwww.clauss.east.de%2Fdownload%2Findex.php&urlref=&_id=d683e115dcac87ed&_idts=1301737622&_idvc=10&_idn=0&_ref=&_refts=0&_viewts=1301846739&pdf=1&qt=1&realp=0&wma=0&dir=0&fla=1&java=1&gears=0&ag=1&res=1920x1080&cookie=1

The Server is Suse Linux 11.1 32bit width PHP 5.2.14, mysql 5.1.49 on an other system (x64) and i use mysqli

In the mysql-table piwik_log_profiling i see 4 insert into piwik_log_visit with a sum_time_ms=1,43 :-?

Thanks


The Request-String from Site clauss-halle.de (is the same site with an other domain):

http://www.clauss.east.de/ausw/piwik/piwik.php?action_name=Downloads&idsite=1&rec=1&rand=0.6090154745915692&h=14&m=45&s=18&url=http%3A%2F%2Fwww.clauss-halle.de%2Fdownload%2Findex.php&urlref=http%3A%2F%2Fwww.clauss-halle.de%2F&_id=052b58d45c68df6e&_idts=1302266696&_idvc=1&_idn=0&_ref=&_refts=0&_viewts=1302266696&pdf=1&qt=1&realp=0&wma=0&dir=0&fla=1&java=1&gears=0&ag=1&res=1920x1080&cookie=1

(vipsoft) #16

The default date shown is “yesterday”. If you change the calendar to “today”, what do you see?


(Matthieu Aubry) #17

In the mysql-table piwik_log_profiling i see 4 insert into piwik_log_visit with a sum_time_ms=1,43 :-?

have you enabled profiling? try to disable this setting for now… Otherwise, send me an email with your FTP login/password & piwik login/pwd and your bug description and link to this forum I can take a look…


#18

I think is enebled with

$GLOBALS['PIWIK_TRACKER_DEBUG'] = true;


#19

Moin :wink:

I have insert a little code to get infos to the insert on piwik_log_visit:

Code in mysqli.php at line 276:

	public function get_error()
	{
		return mysqli_error($this->connection);
	}

in visit.php at line 510 (after $ bind=):

mail("*myaddr*","piwik","$sql\n----\n".print_r($bind,true));

and after Piwik_Tracker::getDatabase()->query( $sql, $bind);:

mail("*myaddr*","piwik-query",Piwik_Tracker::getDatabase()->get_error());

The mail “piwik”:

INSERT INTO piwik_log_visit (idsite, visitor_localtime, idvisitor, visitor_returning, visitor_count_visits, visitor_days_since_last, visitor_days_since_first, visit_first_action_time, visit_last_action_time, visit_entry_idaction_url, visit_entry_idaction_name, visit_exit_idaction_url, visit_exit_idaction_name, visit_total_actions, visit_total_time, visit_goal_converted, referer_type, referer_name, referer_url, referer_keyword, config_id, config_os, config_browser_name, config_browser_version, config_resolution, config_pdf, config_flash, config_java, config_director, config_quicktime, config_realplayer, config_windowsmedia, config_gears, config_silverlight, config_cookie, location_ip, location_browser_lang, location_country, location_provider, location_continent) VALUES (?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?,?)
----
Array
(
    [0] => 1
    [1] => 08:22:05
    [2] => Ö�áܬ�í
    [3] => 1
    [4] => 12
    [5] => 0
    [6] => 7
    [7] => 2011-04-09 06:22:08
    [8] => 2011-04-09 06:22:08
    [9] => 33
    [10] => 1
    [11] => 33
    [12] => 1
    [13] => 1
    [14] => 0
    [15] => 0
    [16] => 1
    [17] => 
    [18] => https://www.clauss.east.de/main/links/index.php
    [19] => 
    [20] => L&€Ä�Èþ
    [21] => WI7
    [22] => FF
    [23] => 4.0
    [24] => 1920x1080
    [25] => 1
    [26] => 1
    [27] => 1
    [28] => 0
    [29] => 1
    [30] => 0
    [31] => 0
    [32] => 0
    [33] => 1
    [34] => 1
    [35] => 3232252161
    [36] => de-de,de,en-us,en
    [37] => de
    [38] => east.de
    [39] => eur
)

and the mail “piwik-query”:

Unknown column 'location_provider' in 'field list'

The field location_provider do not exist in my database


I have Inserts in log_visit :-)))))))


(Matthieu Aubry) #20

strange that the field doesn’t exist, have you installed Piwik from scratch or did you upgrade from a very old version?

try to disable the Provider plugin