Need help with installation -- not showing data


(MSFrick2) #1

Updated 11/17

Hi all,

I am sorry for the post. I have followed the installation instructions and read over the FAQ multiple times. I am still not getting any data.

  1. Dropped all tables, and redid the configuration. Tested some clicks around the website and I am tracking it in the database. I am using PDO MySQL. Attached screen.

  2. Each page of www.fricknet.com contains the Javascript tag. I put it in the because that is where my other tracking cookies are. Is this ok? It seems to be writing to the database.

  3. I have set MySQL to “America/Chicago”.

  4. php.ini time_zone is set to “America/Chicago”.

  5. How come nothing shows?

Thank you.

I am running out of configuration settings to change. style_emoticons/<#EMO_DIR#>/sad.gif

Any help would be much appreciated. This is very befuddling style_emoticons/<#EMO_DIR#>/sad.gif

Thanks,
Michael
michael.sheng@fricknet.com


(vipsoft) #2

Ok. Two problems:

  1. Today is Nov 5th. You’re viewing yesterday.

  2. The VisitGenerator w/MySQLI needs the one line fix in http://dev.piwik.org/trac/changeset/1551


(MSFrick2) #3

I have included pictures of the last 3 days worth of traffic. Also in the meantime, the website has gotten at least 500 uniques that were stored in the database.

I have included shots of the last 3 days traffic as per dashboard and a shot of the database from today. Actually the pics can not be uploaded due to space considerations. Please look at these links:

www.fricknet.com/files/p/piwik1.jpg
www.fricknet.com/files/p/piwik2.jpg
www.fricknet.com/files/p/piwik3.jpg
www.fricknet.com/files/p/db.jpg

Thank you.

[quote=vipsoft @ Nov 5 2009, 11:46 PM]Ok. Two problems:

  1. Today is Nov 5th. You’re viewing yesterday.

  2. The VisitGenerator w/MySQLI needs the one line fix in dev.piwik.org/trac/changeset/1551[/quote]


(vipsoft) #4

Apply the one liner patch and drop your archive tables (Piwik will regenerate them).


(MSFrick2) #5

Hi, I have done so. So, I updated that php file, and dropped all the tables from the database.

I then went to delete config.ini.php to reinstall Piwik.

Afterwards, I generated some fake visits:

  1. I am still getting

Generated 200 unique visitors and 5 actions per visit for the 2009-11-09
Generated 200 unique visitors and 6 actions per visit for the 2009-11-10
Generated 200 unique visitors and 5 actions per visit for the 2009-11-11
Generated 200 unique visitors and 5 actions per visit for the 2009-11-12
Generated 200 unique visitors and 6 actions per visit for the 2009-11-13

Total actions: 5464
Total requests per sec: 58
Object id #101
Fatal error: Call to a member function fetchAll() on a non-object in /var/www/html/piwik/core/Piwik.php on line 253

  1. There is still no data.

Help please.


(MSFrick2) #6

[quote=MSFrick2 @ Nov 5 2009, 10:57 PM]Updated 11/17

Hi all,

I am sorry for the post. I have followed the installation instructions and read over the FAQ multiple times. I am still not getting any data.

  1. Dropped all tables, and redid the configuration. Tested some clicks around the website and I am tracking it in the database. I am using PDO MySQL. Attached screen.

  2. Each page of www.fricknet.com contains the Javascript tag. I put it in the because that is where my other tracking cookies are. Is this ok? It seems to be writing to the database.

  3. I have set MySQL to “America/Chicago”.

  4. php.ini time_zone is set to “America/Chicago”.

  5. How come nothing shows?

Thank you.

I am running out of configuration settings to change. style_emoticons/<#EMO_DIR#>/sad.gif

Any help would be much appreciated. This is very befuddling style_emoticons/<#EMO_DIR#>/sad.gif

Thanks,
Michael
michael.sheng@fricknet.com[/quote]

Sorry, shameless plug to get to beginning of forums.


(vipsoft) #7

PM login information to your dashboard. We’ll take a look.


(YasseR) #8

I’ve sent you an email.
Cause I’ve also had the timings different than my local.


(sweetpie) #9

I also have the same problem. Thanks for sharing your information. My Problem near about fulfill thanks a lot you people.


(ako) #10

I also have the same problem.Please help us.