I’m not sure if this topic has been repeated, but I did do a quick look.
Please, if this project is going to go forward come up with a required naming convention. I downloaded the newest version, and it was latest.zip?!?! I was at least expecting piw_latest.zip, or pwk_latest.zip. A single convention will help enormously down the line. All projects, addons, extensions, etc would have to follow the basics. So updating, maintaining, branching, anything else should be easier down the line.
Just my 2 cents from a new user. And looking forward to this project!