Mysqli prepare error


#1

Hi There.

I just tried installing the latest version of Piwik on a VPS server and i’m getting the error message:
“Mysqli prepare error: This command is not supported in the prepared statement protocol yet”

This kinda makes no sense too me, i’m not sure if its the new version as the old was working fine.

I get the error messages when Piwik makes the SQL tables.

Thanks
Shaq


(Matthieu Aubry) #2

Thanks for the report created ticket at "Mysqli prepare error: This command is not supported in the prepared statement protocol yet" · Issue #3178 · matomo-org/matomo · GitHub

Is that the whole message you get? What step of the install do you get the message?


#3

I fill in the SQL information click continue or whatever it is and than i get that error message. I can’t find anything in the server error logs however


(Matthieu Aubry) #4

Bug is now fixed in SVN, solution: replace your file plugins/Installation/FormDatabaseSetup.php

by this one: http://dev.piwik.org/trac/browser/trunk/plugins/Installation/FormDatabaseSetup.php?rev=6460&format=txt