My piwik version is still old 1.12. I cannot upgrade directly to 2.16

HI team,
My piwik version is still old 1.12. I cannot upgrade directly to 2.16. Seems I need to go to v2 and then 2.16. is that right ?

Im ending up witj charset error utf-8. This is indeed set on config.ini.php too.

please help

Hi there

You can directly upgrade to 2.16.0 from 1.12.

Thanks Matt. However, I end up with Charset set UTF-8 error
The string to escape is not a valid UTF-8 string in "@CoreUpdater/runUpdaterAndExit_welcome.twig

I tried to add charset = utf8 did not help
Tried UTF-8, utf-8, UTF8 none of them helps.

charset= option completely, or use “utf8”. gives me SQLSTATE[42000] [1115] Unknown character set: ‘UTF-8’

Unfortunately there is a bug somehwere and we are still looking for the cause: The string to escape is not a valid UTF-8 string in "@CoreHome/getDefaultIndexView.twig". · Issue #4410 · matomo-org/piwik · GitHub - feel free to leave a comment there