Multisitesplugin with 0.2.35


(zoddzodd) #1

Hello,

I upgraded the multisitesplugin juste after the migration to piwik 0.2.35, but I still have the error :

Fatal error: Unsupported operand types in /var/www/vhosts/*****.com/httpdocs/piwik/plugins/MultiSitesPlugin/Controller.php on line 204

Someone has also that error ?

Thanks for any help !


(Matthieu Aubry) #2

this is being looked at by the developers of the plugin and a new version will be released soon!


(zoddzodd) #3

ok great ! thanks :slight_smile:


(kolchak) #4

Looks like the vars $current and $last are now arrays, not ints… will dig a bit more…


(geniosity) #5

This is probably the most useful plugin available for Piwik (the “Spy” does not work 100% yet). I am struggling without it… Can’t wait until it’s fixed.


(DazzlinDonna) #6

I’m with you, geniosity. I’m pretty much incapable of dealing with my sites’ stats without this plugin. Hoping with you that it gets fixed soon.


(kolchak) #7

Hi all - the MultiSitesPlugin was causing me some pain, so I spent some time last night and managed to get the basic working. I blogged about how to fix the core code on my blog here:

http://karlkopp.com/blog/2009/5/25/piwik-m…er-0237-upgrade


(DazzlinDonna) #8

Hmmm, those changes didn’t fix it for me. All that did was move the error down a few lines.

[quote=kolchak @ May 25 2009, 12:58 AM]Hi all - the MultiSitesPlugin was causing me some pain, so I spent some time last night and managed to get the basic working. I blogged about how to fix the core code on my blog here:

http://karlkopp.com/blog/2009/5/25/piwik-m…er-0237-upgrade[/quote]


(kolchak) #9

I retro-remembered my changes style_emoticons/<#EMO_DIR#>/smile.gif What is the error you are getting now?


(DazzlinDonna) #10

It still gave me the Unsupported operand types error but it moved from line 204 to 208


(kolchak) #11

There is a new version available attached to the ticket here:

http://dev.piwik.org/trac/ticket/389

But I get out of memory errors.

I’ll see if I can fix my ver…


(geniosity) #12

The new version actually works quite well for me.

Only “problem” is the title: “Podsumowanie stron”

But, we’re back in business style_emoticons/<#EMO_DIR#>/biggrin.gif


(DazzlinDonna) #13

Yay, the new version works! You can change the Podsumowanie stron in the MultiSitesPlugin.php file to whatever you want.

[quote=geniosity @ May 25 2009, 08:40 AM]The new version actually works quite well for me.

Only “problem” is the title: “Podsumowanie stron”

But, we’re back in business style_emoticons/<#EMO_DIR#>/biggrin.gif[/quote]


(kolchak) #14

Fixed my mem errors - are you getting the sparklines to work?


(DazzlinDonna) #15

If the sparklines are the little graphs representing evolution over time, then yes, they work fine. As far as I can tell, everything works perfectly. Have you tried clearing your cache?