Missing argument 1 for Piwik\Plugins\Actions\Actions::isSiteSearchEnabled()


#1

Hello, I just upgraded to 2.9.1 and get this error when visiting the site(after signing in):
There is an error. Please report the message (Piwik 2.9.1) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

There is an error. Please report the message (Piwik 2.9.1) and full backtrace in the Piwik forums (please do a Search first as it might have been reported already!).

Warning: Missing argument 1 for Piwik\Plugins\Actions\Actions::isSiteSearchEnabled(), called in /home/websiteReplaced/t.websiteReplaced.com/plugins/Actions/Menu.php on line 20 and defined in /home/websiteReplaced/t.websiteReplaced.com/plugins/Actions/Actions.php on line 110

Backtrace -->

#0 Piwik\Error::errorHandler(…) called at [/home/websiteReplaced/t.websiteReplaced.com/plugins/Actions/Actions.php:110]
#1 Piwik\Plugins\Actions\Actions->isSiteSearchEnabled(…) called at [/home/websiteReplaced/t.websiteReplaced.com/plugins/Actions/Menu.php:20]
#2 Piwik\Plugins\Actions\Menu->configureReportingMenu(…) called at [/home/websiteReplaced/t.websiteReplaced.com/core/Menu/MenuReporting.php:136]
#3 Piwik\Menu\MenuReporting->getMenu(…) called at [/home/websiteReplaced/t.websiteReplaced.com/plugins/CoreHome/Controller.php:139]
#4 Piwik\Plugins\CoreHome\Controller->getDefaultIndexView(…) called at [/home/websiteReplaced/t.websiteReplaced.com/plugins/CoreHome/Controller.php:176]
#5 Piwik\Plugins\CoreHome\Controller->index(…) called at [:]
#6 call_user_func_array(…) called at [/home/websiteReplaced/t.websiteReplaced.com/core/FrontController.php:582]
#7 Piwik\FrontController->doDispatch(…) called at [/home/websiteReplaced/t.websiteReplaced.com/core/FrontController.php:96]
#8 Piwik\FrontController->dispatch(…) called at [/home/websiteReplaced/t.websiteReplaced.com/core/dispatch.php:36]
#9 require_once(…) called at [/home/websiteReplaced/t.websiteReplaced.com/index.php:46]


(Matthieu Aubry) #2

Hi Mike

thanks for the report. could you please create an issue on: Issues · matomo-org/piwik · GitHub and we will follow up to fix it in next version