Migration serveur prob visiteurs uniques


#1

Bonjour,

Depuis quelques jours j’ai migré mon serveur piwik A vers un serveur piwik B plus puissant. Je suis donc parti d’une réinstallation vierge, j’ai bien récupéré tout mon historique et mes données via un dump de la base tout est ok.

Le problème c’est que depuis cette migration je n’ai plus les mêmes stats au niveau des visiteurs uniques. Je suis l’usage avec piwik d’une dizaine de sites j’ai le problème sur tous mes sites.

Exemple avec un site, vers le mardi 10 mars migration, puis les jours suivant changement, mes visiteurs uniques (en bleu) sont pratiquement équivalents à mes visites (en rouge) :

J’ai pourtant bien répercuté les paramètres de proxy exactement les mêmes que j’avais appliqué sur l’ancien serveur :

[General]
proxy_client_headers[] = “HTTP_X_FORWARDED_FOR”

Auriez-vous une idée ? Un paramètre que j’aurai oublié ?

Merci d’avance


(Matthieu Napoli) #2

Bonjour,

Y’a-t-il eu un changement de version de Piwik au passage ? Il est possible que le bug en question soit celui là : Unique visitors and Visits since 2.11.0 almost the same · Issue #7290 · matomo-org/piwik · GitHub

Dans ce cas il faudrait mettre à jour à la dernière version (2.11.2 ou plus).


#3

Bonjour,

Merci pour votre réponse c’est exactement ca, lors de la migration sur le nouveau serveur j’ai eu une mise à jour au passage. Je suis en 2.11.1 je vais passer la mise à jour je vous fais un retour si c’est ok.

Merci


#4

Bonjour,

Tout est rentré dans l’ordre.

Merci Beaucoup.