Maxmind's GeoIP 2 Lite database and warning "you are not using one of the recommended providers"

Hi Folks,

I use the Maxmind’s GeoIP 2 Lite database, on nginx level and set them up correctly in my settings. My gives the correct info and I used these references to setup matomo. But I still get the warning


Geolocation works, but you are not using one of the recommended providers. If you have to import log files or do something else that requires setting IP addresses, use the PHP GeoIP 2 implementation and install maxminddb extension.


How to get rid of that warning?