Maximum execution time does not change


When querying Piwik for longer periods I get the error message about Maximum Execution Time stating “time of 30 seconds exceeded” in one of the Piwik PHP files.
What puzzles me is that my setting in PHP.INI is 60 seconds, which is clearly stated when I run phpinfo command. Why would Piwik hang to that 30 seconds I set it to something else? I watched the clock and it really times out after 30 seconds.

My PHP.INI settings have been there forever so restarting Apache should not be the cause.


try update both PHP.ini, the CLI and the APACHE one

Thanks for the reply.

I’m not sure what CLI and APACHE php.ini would exactly be.

What I do know is that when I run phpinfo command, I see my settings of 60 seconds in both Local and Master value columns.

My hosting is a simple shared package.


please ask your webhost as it’s config issue