Max execution time


#1

Hello folks

I am trying to adjust the max_execution_time from 30 to 60 seconds. I can see the change I made in “config.ini.php” file under Diagnostics/Config file in Matomo, however the max_execution time is still show as 30 sec in the error logs.

My question is; Is there another config file that needs to be updated and/or could a plugin need to be configured?

Thanks in advance!
Geo


(Fabian Dellwing) #2

I guess you need to change this in your php.ini file.


#3

Hey Fabian,

Right, that’s what we expected too. However, I have updated the “php.ini”, no success. I have also updated the “global.ini”, no success.

It seems like Matomo is grabbing the config from different .ini file or maybe a plugin?

Any other ideas?
Geo


(Peterbo) #4

Execute a phpinfo() command to see which ini files are involved.


(Fabian Dellwing) #5

And make sure to restart you apache2 or php-fpm server.


#6

Not running apache2 or php-fpm. phpinfo() shows /etc/php.ini is being read.
The Apache server has been restarted multiple times, max_execution_time has been changed to 60 and 0 with no effect. I can’t find any other config setting controlling this. However, when we start loading some of the data in Matomo, this is generated in the ssl_error_log;

PHP Fatal error: Maximum execution time of 30 seconds exceeded

About to pull my hair out.


(Fabian Dellwing) #7

I digged throught all the code and the only function that changes the max_execution_time is this one:

I then checked for calls to this function and there are 6 (+1 test), but all of these calls are setting it to 0. So this has to be an unrelated issue?

Without more information about your environment it will be hard to help you with this.