Matomo Setup highly Unstable

Hey guys

I’m having trouble with my matomo in my openshift. This matomo is rather unstable.

When I start the pod motomo runs fine for a short time (very short time). Then matomo starts to respond with http 504 regularly … eventualy beeing unable to process any request successfully and respond with 504 only.

My guess is that matomo tries (lots of) communication with the internet. My openshift is not allowed to communication with the internet. Could this be the cause of trouble?

What is the recommended setup for matomo in general and matomo in openshift in particular?

Best Regards
Sebastian

Hi,

If your Matomo-Webserver is not able to connect to the internet, I’d recommend you to follow this guide:

With these options (especially enable_internet_features) Matomo won’t try and things should work better.

I followed the same steps, as you shown in the article! but nothing worked.