Matomo not showing correct ip with cloudflare (Nginx/fpm)


(Skyrider) #1

I recently just installed Matomo, and I noticed that all IP addresses that are logged are using cloudflare’s IP addresses. And yes, I already enabled the correct proxy headers according to:

https://matomo.org/faq/how-to-install/faq_98/

I even have a list of all cloudflare IP’s set up in a config file:

https://marekbosman.com/site/automatic-update-of-cloudflare-ip-addresses-in-nginx

Just a small note. This does work on Xenforo, all IP’s shown there are real IP’s. I even created a simple php script to return my IP address (on a cloudflare DNS enabled domain) and it returns my own IP just fine.

So, what’s going on? Why isn’t it working? The config file itself appears to work, as I also added an SSL force which worked just fine.


(Skyrider) #2

Nvm… After some research, it was the anonymize ip settings.