Matomo is still not capturing anything after installation for 2 hours

Hi, a little bit of context.

I’ve hosted my Matomo into aws ec2 instance and decided to connect it to my website created by wordpress.

I’ve done the installation and everything. Added the tracking code before the end of head tag in wordpress. And tried revisiting my site using different user profile but it is not showing up.

I also tried to install the WP-Piwik and sucessfully connected it with my self hosted Matomo instance.

Until now, nothing had show up.

I’ve checked all of my pages and found the matomo script included with matomo.js.

I’d like to know whether I am missing some steps hence it is not capturing anything from my instance.

Thanks in advance.

Hi, have you checked Piwik doesn't track any visits and pages, and shows "There is no data for this report" in all reports. FAQ - Analytics Platform - Matomo

Hi i’ve checked all and all the relevant ones I am doing it correctly. Yet it is still not showing anything.

Any takers please?

Thanks!

Hi,

Can you open your browsers developer tools on the website that is tracking and check for errors?

Also check that no adblocker or enabled DoNotTrack are keeping your data from showing up in Matomo.

And check the visitor log in Matomo. If you see data there, but no reports, then it is an archiving problem.

Hi thank you for the response!

I’ve not installed adblocks or enabling DNT in my browser.

Checked it with my developer tools and no errors is shown.

Even in visitor log it just shows that there is no data in this report.

Hi,

I’m running out of remote-debugging-tips, so if you want to, can you please send me a private message with the URL to the tracked site?

Hi thank you for the kind assistance.

The url of the tracked site is https://eber.co

And the aws instance that I used to host matomo is
http://54.254.219.158/matomo/index.php?module=CoreHome&action=index&idSite=1&period=day&date=yesterday

Hi,

HTTPS can’t embed non-HTTPS resources as that would undermine all security. And as I doubt you have an SSL cert for 54.254.219.158, no data can be sent to Matomo.

Ah i got it now, will update you if everything is working as intended now!

Thanks a bunch!

This post was flagged by the community and is temporarily hidden.