Matomo installation giving zlib error

I have installed PHP with below extensions, however Matomo system check is saying zlib not installed. Please help us we are stuck here. Attaching system check.

./configure --enable-fpm --with-mysqli --enable-gd --with-zlib