Matomo Forms missing fields

Hi,
we’re using Form Analytics for our website. Most of it works good, but we noticed that all radio buttons are not tracked. Is that on purpose?
For example: At https://myinsurance.lamie-direkt.at/haushaltsversicherung#/step1 the form itself is tracked, also the first and the last input fields are shown, but all radio buttons aren’t tracked. Did we make a mistake here? I couldn’t find anything in the FAQ that would help me.

Kind regards

Hi Hans,

Having quick look at the site, everytime a radio button is clicked there is a JavaScript error. This maybe causing the tracking to fail. Can you please rectify this first and try again?

Hi Jason,
thanks for the hint. The error has been fixed, but the problem occurred before this was built in. The only idea I have is that radio buttons who share the same ‘category’ have the same name attribute (but different IDs). Could that be a reason why Matomo doesn’t track them?

Hi Hans,

We have had another look and it seems you have the tag manager and regular tracking code in place. You would need to use one or the other for the plugin to work. Is there a reason you need both in your page?

Thanks,

Hi Jason,

the plugin worked the same before the Tag Manager Code was implemented. Could the name attribute as mentioned above be the reason?
We understood that we need the Matomo tracking code as well as the Tag Manager Container Tracking Code installed so both are working. Is that incorrect?

Kind regards

So? Could that be the reason?

Hi,

You should use one or the other. Please remove one and try again,

Thanks,

facing the same issue in my website using the trial version for now